Audi A4 Check Engine Light On - AudiForums.com
AudiForums.com

Go Back   AudiForums.com > Audi Models > Audi A4
Sign in using an external account
Register Forgot Password?
Search

Audi A4 The Audi A4 model offers nimble handling and performance that makes it one of the leading cars in its class. Read more about the Audi A4 in the Audi A4 review.

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-10-2006, 03:27 AM
dsp dsp is offline
 
Join Date: Dec 2006
Posts: 2
Default Audi A4 Check Engine Light On

I have a 2001 A4 90000 miles on it. The Check Engine Light is always on. I took it to two different audi dealerships and they changes the O2 sensor, and the air flow sensor, but the light keeps returning back on.

Any ideas ?

Thanks in advance,

Mark
Reply With Quote
  #2  
Old 12-10-2006, 03:31 AM
turbo kraut's Avatar
Tech Guru

 
Join Date: Nov 2006
Location: Des Peres, Mo
Posts: 5,865
turbokraut boosted18t turbo_kraut
Default RE: Audi A4 Check Engine Light On

what are the codes you are getting, go to autozone or a local parts store get your car scanned and let people know what the code is, like p1041 p1613

that will make it easier for people to help
__________________
2001 Honda CBR929RR - modded - mine
1992 Ford Bronco - The Beast - mine
2011 Ninja 250r - wifes
2009 Pontiac Vibe - stock - wifes
2001 Audi A4 1.8t - RIP 3-31-13
Reply With Quote
  #3  
Old 12-10-2006, 11:45 AM
1st Gear
 
Join Date: Dec 2006
Posts: 5
Default RE: Audi A4 Check Engine Light On

is it running rough at all?? especially on startup when it's cold out??
I had a coolant temperature sensor cause that. I also had sensors up and downstream of CATs give bad readings, and they tried to tell me that i needed new CATs, but it turned out it just needed a computer re-program, there was a technical service buliten out on it, but mine is a 2000
Reply With Quote
  #4  
Old 12-10-2006, 08:58 PM
dsp dsp is offline
 
Join Date: Dec 2006
Posts: 2
Default RE: Audi A4 Check Engine Light On

Hi Guys,
Thanks for replying, The error is P0411 (Secondary Air injection system - Incorrect flow)

The audi dealer ship replaced 2 sensors : Oxygen sensor, AirFlow sensor.

The car starts fine, and when i am driving it feels like the car lost 30 hp.

Thanks in advance
Mark
Reply With Quote
  #5  
Old 12-10-2006, 09:29 PM
1st Gear
 
Join Date: May 2006
Location:
Posts: 38
Default RE: Audi A4 Check Engine Light On

The reason it feels like it has 30 hp less is because it prolly is at least 30 HP less, if not even more than that. When your cel comes on the ecu goes into limp mode and will open the wastegate at 4psi instead of 10 psi to avoid detonation if its a missfire problem. One tip I have been told in the past with the B5 1.8t's is to take off the maf sensor and clean the inside of it very thouroghly with a little bit of electronic safe cleaner found at most retail stores that sell computers. The sensor is very sensitive to dirt and can cause a cel stating it is from another source in the fuel system. Give it a shot. You've already done everything else. It will take you prolly a half hour and $10 for the cleaner. Not to mention you may have to go back to the dealer and have the light shut off. Good Luck!!!!
__________________
02 A4 1.8t fwd, APR stage 1+, APR snub, 3" turbo back, test pipe, forge 007, k&n, fmic, hid's, lowered, 18" Konigs, alpine dvd, alpine type r components, type r coaxials, alpine v12 4 ch, alpine v12 mono, 2-10" alpine type r subs, License Plate-IMFASTR.
Reply With Quote
  #6  
Old 06-30-2007, 02:06 PM
1st Gear
 
Join Date: Jun 2007
Posts: 8
Default RE: Audi A4 Check Engine Light On

Just wonderin what the MAF sensor is. what does that sound like and where is it located in the 1.8t's engine bay? thanks ive got this same code on my a4.
Reply With Quote
  #7  
Old 06-30-2007, 02:52 PM
onepoint8tee's Avatar
Site Moderator
 
Join Date: Sep 2005
Posts: 13,665
Send a message via AIM to onepoint8tee
Default RE: Audi A4 Check Engine Light On

You dont need to resurect old threads to ask questions, either post a new thread or just use the search.

The MAF sensor measures how muchair is entering the intake/engine so the ECU can compensate for fuel/timing, etc. It doesnt sound like anything. Its located inside the airbox, your turbo inlet pipe is connected to it on the front.
__________________
Reply With Quote
  #8  
Old 11-19-2007, 11:19 AM
1st Gear
 
Join Date: Nov 2007
Posts: 10
Default RE: Audi A4 Check Engine Light On

P0411 error is for the secondary air flow, which is connected to the air box, but separate from the main intake. TheMAF sensor is located in the in the path of main intake, so how is the MAF sensor reading affecting secondary air when it is a different path? I have the same problem, and in search for a solution.
Reply With Quote
  #9  
Old 11-19-2007, 03:38 PM
4th Gear
 
Join Date: May 2004
Location: Northern NJ USA
Posts: 4,035
Default RE: Audi A4 Check Engine Light On

He meant MAF when he said he replaced the airflow sensor.
He has a problem with the secondary air injector .
__________________
2009 Subaru Impreza 2.5i Auto 4dr Premium

Previous Car
2001 A4 1.8T Q Casablanca White, Tip, ESP, Xenon and Premium
Reply With Quote
  #10  
Old 05-05-2009, 02:53 PM
h4x0r's Avatar
1st Gear
 
Join Date: Mar 2009
Posts: 69
Default

Quote:
Originally Posted by dsp View Post
Hi Guys,
Thanks for replying, The error is P0411 (Secondary Air injection system - Incorrect flow)

The audi dealer ship replaced 2 sensors : Oxygen sensor, AirFlow sensor.

The car starts fine, and when i am driving it feels like the car lost 30 hp.

Thanks in advance
Mark
I have the same problem. My mechanic told me that he still needs to check some fuses and parts of the electrical system because the Air injection system is not working at all, but just for curiosity, how much did the dealer charged you?
Reply With Quote
  #11  
Old 06-11-2009, 07:53 PM
2nd Gear
 
Join Date: Apr 2005
Location:
Posts: 1,170
Default

the secondary air injection system is a smog controll for cold starts.

when the car is cold so is the catalytic converter and the the cat needs to be hot in order to filter out harmful exhaust gas effectively. the air pump mixes in atmospheric air into the exhaust gas stream before the cat to help the cat heat up to max effeciency faster.

What the secondary air injection system consists of is a coolant temp sensor, a valve, and an air pump. when the car is cold the coolant temp sensor basically trips the air pump to turn on and open's the combination or "combi" valve. very often on cars over or near 100k miles is one gets carbon buildup in the combi valve and it causes to stop working.

if that is not the trouble like stated above, then either the coolant temp sensor is bad or the actual pump is broken, which is pricey.

diy solution: find the combi valve (search audiforums), and clean it with some carburator cleaner. then find the air pump, and send some electricity through the pump and see if it pumps. then check the fuse. if everything is ok then clear the code and see if it comes back. if it does then its probably time for a new coolant temp sensor.
__________________
'98 A4Q 1.8T 5spd

snubbed
ECS Slotted rotors
DG SS
APR Stage 1
VDO boost and oil pressure a-pillar gauges
Reply With Quote
  #12  
Old 07-04-2011, 06:36 AM
1st Gear
 
Join Date: May 2011
Posts: 2
Default MAF Sensor for Audi A4 Quattro 1.8

My "check engine" light has been on for months. I had a shop replaced the air hosts and tube, replaced the O2 sensor ans spend almost $1,000, but the check engine light came back on again. The error code is P0171 and the car would not pass emission test. One other option is to fix is the MAF sensor. I am trying to do it myself (clean it), but I could not locate it. I had removed the covers and look at the air intake that goes to the engine, but I could not recognize the MAF sensor to remove it. Can any one help? Thanks!
Reply With Quote
  #13  
Old 12-01-2011, 06:18 PM
1st Gear
 
Join Date: Dec 2011
Posts: 2
Exclamation Engine light came on

I drive an 06 A4 2.0T sedan approx 105,000kms on it. First time owning an Audi and need some help!!!

Engine light came on out of nowhere, so had it checked with an odbII reader.
DTC 02,I/M NO. Fuel trim,bank1 system too lean. No idea what that could be. Friend reseted it for me, engine light came off. Few hours later came back on.

Started it and noticed engine running sluggish sounds extremely louder than normal. About 5mins after running it started smelling like gasoline. Been trying to follow numerous forums not exactly sure what to do from here.

No pan heater, transmission flush not completed yet, still under warranty power train. Recently got a warranty extension sent from Audi re: recall for the Intake manifold runner control motor, "fuel pressure sensor (G410), and positive crankcase ventilation (PCV) Valve. Just curious whether this would be in relation to the engine light coming on and Dtc p0171 code being the fault code.

IN NEED OF SOME SERIOUS HELP GUYS, as can't bring my vehicle in Audi dealership until 2wks.
Reply With Quote
  #14  
Old 12-10-2011, 07:59 AM
1st Gear
 
Join Date: Oct 2011
Posts: 1
Default

My check engine came on and is still on I it use high end gas and is maintained every 4000 mile and could it be my spark plugs
Reply With Quote
Old 12-10-2011, 07:59 AM
 
 
 
submit to reddit
Reply


Tags
2001, 2004, a4, a6, audi, check, chekc, codes, engin, engine, light, lihgt, p0411, rough, running


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


 

Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
Audi Custom Rims
K&N Engineering, Inc.
GetCoolParts.com
TunerDomes
Advertise here
All times are GMT -4. The time now is 05:43 AM.

Internet Brands, Inc.
Emails Backup