AudiForums.com

Go Back   AudiForums.com > Audi Models > Audi A4
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Parts Search Today's Posts Mark Forums Read ExperienceGarageUsed CarsVendor Directory
Search
Welcome to AudiForums.com

Audi A4 The Audi A4 model offers nimble handling and performance that makes it one of the leading cars in its class. Read more about the Audi A4 in the Audi A4 review.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-03-2007, 03:10 AM
1st Gear
 
Join Date: Nov 2005
Location:
Posts: 31
Default Need help! car starts and then dies.

OK 1999 A4 AEB - One of the kids left the light in the back on and it drained the battery dead. It was dead for 2-3 days probably. I charged the battery and now the car will start fine, run for about 1-2 sec and then die. Same thing every time. I can keep it running if I feather the throttle on and off but its horrible. I've tried to do the throttle valve adjustement by clearing the codes and leaving the key on, engine off for 20 mins and then starting it but it didn't help.

Anyone with an idea? I don't have a VAG but I am using an aftermarket scan tool and it shows a P1545 (which has to dowith the throttle valve) in the memory but its not currently setting a CEL.

Is there anyway that the dead battery activated that theft prevent deal where it won't let an unknown ECU work?

Let me hear your ideas. Right now the battery is disconnected and back on the charger overnight in hopes things may reset themselve in the morning?

__________________
Braden
1999 Audi A4 1.8TQA
  #2  
Old 01-03-2007, 03:17 AM
onepoint8tee's Avatar
Site Moderator
 
Join Date: Sep 2005
Posts: 13,665
Points: 26,392, Level: 97
Points: 26,392, Level: 97 Points: 26,392, Level: 97 Points: 26,392, Level: 97
Level up: 5%, 958 Points needed
Level up: 5% Level up: 5% Level up: 5%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Send a message via AIM to onepoint8tee
Default RE: Need help! car starts and then dies.

Try disconnecting the battery for 30 mins and then doing another TBAwhen you reconnectand see what happens.
__________________
  #3  
Old 01-03-2007, 03:21 AM
1st Gear
 
Join Date: Jun 2006
Location:
Posts: 434
Default RE: Need help! car starts and then dies.

Yeah I think your on the right track with the throttle valve adaptaion. When you disconnect the batt. there is a whole list of things you have reset. You will probably need vag com to do it right though. I dount know if you know anything about value blocks but its #60 of you ever get your hands on a vag com
__________________
  #4  
Old 01-03-2007, 12:15 PM
1st Gear
 
Join Date: Nov 2005
Location:
Posts: 31
Default RE: Need help! car starts and then dies.

I disconnected the battery overnight and let it sit on the charger to make sure it was fully charged. I hooked it up this morning and now it won't even start. Looks like I'm going to be visiting the ross-tech website because I feel like I'm working on it blind without one.

Any ideas?
__________________
Braden
1999 Audi A4 1.8TQA
  #5  
Old 01-03-2007, 02:42 PM
onepoint8tee's Avatar
Site Moderator
 
Join Date: Sep 2005
Posts: 13,665
Points: 26,392, Level: 97
Points: 26,392, Level: 97 Points: 26,392, Level: 97 Points: 26,392, Level: 97
Level up: 5%, 958 Points needed
Level up: 5% Level up: 5% Level up: 5%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Send a message via AIM to onepoint8tee
Default RE: Need help! car starts and then dies.

I think your battery is shot.
Can you describe what happens now when you turn your key to the on position? Do your lights on the dash come on? Any clicking when you go to start it? Are you sure you had it hooked up to your charger the right way over night? If your car is a manual try to start it by someone pushing it and then pop the clutch and see what happens. If it runs and keeps a charge youll know its not the battery but maybe your starter or something else. I know that would be unlikely, but it could be a crazy coincidence.
There are only5 things that need to be done/reset after the battery is disconnected:
1. Radio safety code
2 Radio presets
3. Re program one touch power windows up/down (simple)
4. Reset clock
5. Throtle body adaptation

Also what voltage do you have when your key is in the on position? If its much less than 12 your car isnt gunna start. Most accurate way to do it is hook up a volt meter, our gauges on the dash arent the most accurate.
__________________
  #6  
Old 01-03-2007, 02:59 PM
1st Gear
 
Join Date: Nov 2005
Location:
Posts: 31
Default RE: Need help! car starts and then dies.

Sorry for not being more clear but it will crank but not start. Charge on battery is fine and I'm getting all 12V. I'm wondering if the throttle adaptation occurred. I cleared the codes, turn the key on and engine off for 20 min and then started it - cranks but no go. Is there any other methods toperform the adaptation? I have order a Vag-Com as I see I'll need one so I can stop wasting time but if I can get it running tonight it would be good.

Has anyone had similiar problems after a simple dead battery - doesn't make sense why a dead battery would cause such an issue.
__________________
Braden
1999 Audi A4 1.8TQA
  #7  
Old 01-03-2007, 03:21 PM
onepoint8tee's Avatar
Site Moderator
 
Join Date: Sep 2005
Posts: 13,665
Points: 26,392, Level: 97
Points: 26,392, Level: 97 Points: 26,392, Level: 97 Points: 26,392, Level: 97
Level up: 5%, 958 Points needed
Level up: 5% Level up: 5% Level up: 5%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Send a message via AIM to onepoint8tee
Default RE: Need help! car starts and then dies.

How are you performing the TBA? You dont need to wait 20 mins.
Pop the hood, open the driver door, turn key to the accessory on position, wait about 1 minute or so untill you no longer hear a high pitched whine from the throttle body.[/align][/align][/align]
__________________
  #8  
Old 01-04-2007, 01:44 AM
1st Gear
 
Join Date: Nov 2005
Location:
Posts: 31
Default RE: Need help! car starts and then dies.

OK. I removed the Throttle body and cleaned it and reinstalled it. I disconnected the battery for 30 minutes and then reconnected it. I turned the key on while keeping the engine off and heard the typical relays and a very quick quick throttle move from the throttle body module but then it stopped so I don't think it is performing the TBA on its own. I scanned it again and everytime I turn the key on I immediatly get a P1545 code and this may be keeping it from performing the TBA. I erase it and turn it off and then on again and its there again. I fear the throttle body is going to need to be replaced. I've got a Vag-com coming and if I can't get it to perform the TBA I'll have to pony up the $$$.

Anyone know why a throttle body would go bad at the same time as a dead battery or has it been bad for awhile and it was only when I had the dead battery that I discovered it?
Where can I buy a throttle body on-line for a good price?
__________________
Braden
1999 Audi A4 1.8TQA
  #9  
Old 01-08-2007, 12:51 PM
1st Gear
 
Join Date: Nov 2005
Location:
Posts: 31
Default RE: Need help! car starts and then dies.

So the car is running again. The problem I was having was that after I charged my battery and attempted to star the car it must not have met al off the TBA conditions and malfunctioned. When it did this is threw a P1545 code that would appear everytime the key was turned ON. All subsequent attempts to reset ECU and perform the TBA failed as the P1545 would always return at Key ON and prevent the TBA from performing and correcting itself. What was necessary was to hook up the Vag-com, turn the key ON and monitor the '098' measure block. It stated that the status was in fact "ERROR". I then went to pending DTC's and found the P1545 code as I expected. I cleared this code and then went back and performed the TBA manually as described on the Ross-Tech website. The TBA worked and the she started right up.

Maybe this will help someone down the road.
__________________
Braden
1999 Audi A4 1.8TQA
Old 01-08-2007, 12:51 PM
 
 
 
Reply


Tags
1999, a4, audi, battery, car, cranks, dead, dies, key, p1545, quick, stalls, start, starts, tba, wait


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
New Sponsors

All times are GMT -4. The time now is 09:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Internet Brands, Inc.
Emails Backup