AudiForums.com

Go Back   AudiForums.com > Audi Models > Audi A4
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Parts Search Today's Posts Mark Forums Read ExperienceGarageUsed CarsVendor Directory
Search
Welcome to AudiForums.com

Audi A4 The Audi A4 model offers nimble handling and performance that makes it one of the leading cars in its class. Read more about the Audi A4 in the Audi A4 review.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-04-2006, 04:19 PM
1st Gear
 
Join Date: Feb 2006
Location:
Posts: 80
Default Trying to diagnose tach not working problem...

My tachometer doesn't work half the time and here's an interesting thing that I noticed: When the abs/blinking brake light isn't flashing, the tach works. When it is flashing, the tach doesn't work. If I start driving with the lights still not blinking, then the tach will continue working but if i start the car and they light up right away then the tach doesn't work either. Really wierd and maybe not related but thought this might be connected somehow. So, how do i diagnose this tachometer not working problem?
  #2  
Old 04-09-2006, 01:36 PM
3rd Gear
 
Join Date: Oct 2005
Location:
Posts: 2,646
Points: 4,930, Level: 44
Points: 4,930, Level: 44 Points: 4,930, Level: 44 Points: 4,930, Level: 44
Level up: 90%, 20 Points needed
Level up: 90% Level up: 90% Level up: 90%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default RE: Trying to diagnose tach not working problem...

You have data bus issues most likely caused by a faulty abs control module.
  #3  
Old 04-09-2006, 07:14 PM
1st Gear
 
Join Date: Feb 2006
Location:
Posts: 80
Default RE: Trying to diagnose tach not working problem...

Thanks for your input...
Would a scan show what exactly is wrong - if it's really a abs control module or if it's something else?
  #4  
Old 04-12-2006, 02:16 AM
3rd Gear
 
Join Date: Oct 2005
Location:
Posts: 2,646
Points: 4,930, Level: 44
Points: 4,930, Level: 44 Points: 4,930, Level: 44 Points: 4,930, Level: 44
Level up: 90%, 20 Points needed
Level up: 90% Level up: 90% Level up: 90%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default RE: Trying to diagnose tach not working problem...

Unfortunalty you usually dont get a code related to the symtoms you describe but if the problem is fairly repeatable try unplugging the abs control module. If your problem disapears, you have yor faulty part.
  #5  
Old 04-12-2006, 02:36 AM
1st Gear
 
Join Date: Feb 2006
Location:
Posts: 80
Default RE: Trying to diagnose tach not working problem...

What exactly does the ASR button on the dash do? Becuase when the car is running and the lights on the speedometer aren't flashing, then when I press that button, a yellow light shines up on the speedometer (a triangle with a circle arrow around it- next to green light's-on sign) and nothing else happens - just that one yellow light shining. When the lights are blinking (the abs light-shining, brake light flashing, low oil pressure light blinking when I'm not at idle, and the three beeps, and tach at zero - not responding) and I press the ASR button then nothing happens at all. It's really wierd, I can be driving and the tach works and no lights when all of a sudden the tach needle goes down to zero and lights come up at the same time, along with four beeps. Or I can start the car and all those lights are on and tach doesn't work, when all of a sudden they all stop shining and tach starts working. This is obviosly something electrical - wiring gone bad or something like that. What do you guys think?
  #6  
Old 04-16-2006, 12:41 PM
3rd Gear
 
Join Date: Oct 2005
Location:
Posts: 2,646
Points: 4,930, Level: 44
Points: 4,930, Level: 44 Points: 4,930, Level: 44 Points: 4,930, Level: 44
Level up: 90%, 20 Points needed
Level up: 90% Level up: 90% Level up: 90%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default RE: Trying to diagnose tach not working problem...

Asr is your traction control. The light lights up letting you know you have turned it off. Default position is on. It contorls wheel spin using the abs system. So when your abs light is flashing and not working. Your asr cannot work either.
  #7  
Old 05-19-2006, 10:57 PM
1st Gear
 
Join Date: Feb 2006
Location:
Posts: 80
Default RE: Trying to diagnose tach not working problem...

Ok, I diconnected my ABS Control Module ands the low oil pressure light has dissapeared and the tach started working again. But the abs is on and brake light is still blinking. Does that mean that my abs control module is bad? Where can I get one for a good price? Dealer is out of question - way to high in price. thanks for any input!
  #8  
Old 05-19-2006, 11:25 PM
3rd Gear
 
Join Date: Nov 2005
Location:
Posts: 2,333
Points: 9,662, Level: 66
Points: 9,662, Level: 66 Points: 9,662, Level: 66 Points: 9,662, Level: 66
Level up: 3%, 388 Points needed
Level up: 3% Level up: 3% Level up: 3%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default RE: Trying to diagnose tach not working problem...

ya you need another sensor...try a junkyard, they hook people up pretty decently.
__________________

WWJD
1996 2.8 12v - RIP
2001 2.8 30v - SikWidIt, too much to list..
  #9  
Old 05-20-2006, 01:51 AM
4th Gear
 
Join Date: May 2004
Location: Northern NJ USA
Posts: 4,016
Points: 8,556, Level: 62
Points: 8,556, Level: 62 Points: 8,556, Level: 62 Points: 8,556, Level: 62
Level up: 36%, 194 Points needed
Level up: 36% Level up: 36% Level up: 36%
Daily Activity: 13.8%
Daily Activity: 13.8% Daily Activity: 13.8% Daily Activity: 13.8%
Default RE: Trying to diagnose tach not working problem...

http://www.modulemaster.com/
__________________
2009 Subaru Impreza 2.5i Auto 4dr Premium

Previous Car
2001 A4 1.8T Q Casablanca White, Tip, ESP, Xenon and Premium
  #10  
Old 08-25-2012, 02:47 PM
1st Gear
 
Join Date: Jul 2012
Posts: 23
Points: 529, Level: 10
Points: 529, Level: 10 Points: 529, Level: 10 Points: 529, Level: 10
Level up: 58%, 21 Points needed
Level up: 58% Level up: 58% Level up: 58%
Daily Activity: 2.0%
Daily Activity: 2.0% Daily Activity: 2.0% Daily Activity: 2.0%
Default

resurrecting an old thread, as I have this same problem, but mine seems to be permanent and NOT intermittent. Where is the ABS module and is is fairly obvious as to what needs to be done to disconnect it?
Old 08-25-2012, 02:47 PM
 
 
 
Reply


Tags
2001, 80, a4, ans, audi, brakw, diagnose, faulty, light, problems, responding, silverado, sport, st, tach, tachometer, work, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
New Sponsors

All times are GMT -4. The time now is 07:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.
Internet Brands, Inc.
Emails Backup