AudiForums.com

Go Back   AudiForums.com > Audi Models > Audi A6
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Parts Search Today's Posts Mark Forums Read ExperienceGarageUsed CarsVendors TSBs
Search
Welcome to AudiForums.com

Audi A6 The mid-sized Audi A6 model offers more room to the driver and passengers over the A4 line.
Sponsored by Audi USA Parts
Click Here


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-01-2009, 11:47 AM
1st Gear
 
Join Date: Jan 2008
Posts: 17
Points: 3,374, Level: 36
Points: 3,374, Level: 36 Points: 3,374, Level: 36 Points: 3,374, Level: 36
Level up: 16%, 126 Points needed
Level up: 16% Level up: 16% Level up: 16%
Daily Activity: 3.3%
Daily Activity: 3.3% Daily Activity: 3.3% Daily Activity: 3.3%
Default Fuel gauge show empty

Hi

I have a 2006 2.7TDi. The fuel gauage shows empty, it happened quite quick, within an hour from 1/2 tank to need to refuel, so refuelled full tank, now shows totally empty, nothing there and stays like that, no change.

Audi dealer says fuel sender not working, need to replace fuel pump!!!, why is this?

cheers

krish
  #2  
Old 06-01-2009, 12:47 PM
chefro's Avatar
3rd Gear

 
Join Date: Dec 2008
Location: IL
Posts: 1,941
Points: 7,883, Level: 59
Points: 7,883, Level: 59 Points: 7,883, Level: 59 Points: 7,883, Level: 59
Level up: 67%, 67 Points needed
Level up: 67% Level up: 67% Level up: 67%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default

I think they try to gyp you.
You only need to replace the Fuel Level Sensor, which actually is ON TOP of the fuel pump. I bet they will charge you for a "new" pump and will leave the old one in.
The level sensor has a floater that is not dependent in any shape or form of what the fuel pump does.
I don't think the TDIs (diesel?) have a much different fuel pump/supply.
If they do, I apologize for the wrong info.
__________________
'95 12V - 167,400 miles - engine rebuild + ps fluid and ATF change; switched to Mobil1Syn 0W-30 at 158,200; Purchased Dec. 2008 @ 152,100 miles - Presently 182,500 miles

Last edited by chefro; 06-01-2009 at 12:50 PM.
  #3  
Old 06-01-2009, 01:40 PM
1st Gear
 
Join Date: Jan 2008
Posts: 17
Points: 3,374, Level: 36
Points: 3,374, Level: 36 Points: 3,374, Level: 36 Points: 3,374, Level: 36
Level up: 16%, 126 Points needed
Level up: 16% Level up: 16% Level up: 16%
Daily Activity: 3.3%
Daily Activity: 3.3% Daily Activity: 3.3% Daily Activity: 3.3%
Default

they said it comes within it or as one unit
  #4  
Old 06-01-2009, 10:34 PM
chefro's Avatar
3rd Gear

 
Join Date: Dec 2008
Location: IL
Posts: 1,941
Points: 7,883, Level: 59
Points: 7,883, Level: 59 Points: 7,883, Level: 59 Points: 7,883, Level: 59
Level up: 67%, 67 Points needed
Level up: 67% Level up: 67% Level up: 67%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default

It looks like nobody selling parts lists the 2006 2.7 TDI model.
Unless it is strange, it looks like the dealer has a niche with this model. Maybe that's the way the pump indeed comes as a "whole" unit, but I would really like to see it at the dealer.
Vagcat.com is also "mute" about this particular engine, so... I'm affraid you'll have to "trust" them.
__________________
'95 12V - 167,400 miles - engine rebuild + ps fluid and ATF change; switched to Mobil1Syn 0W-30 at 158,200; Purchased Dec. 2008 @ 152,100 miles - Presently 182,500 miles
  #5  
Old 06-02-2009, 06:18 AM
2nd Gear
 
Join Date: Jan 2005
Location:
Posts: 1,373
Points: 7,096, Level: 55
Points: 7,096, Level: 55 Points: 7,096, Level: 55 Points: 7,096, Level: 55
Level up: 73%, 54 Points needed
Level up: 73% Level up: 73% Level up: 73%
Daily Activity: 5.1%
Daily Activity: 5.1% Daily Activity: 5.1% Daily Activity: 5.1%
Default

Quote:
Originally Posted by krishcanag View Post
Hi

I have a 2006 2.7TDi. The fuel gauage shows empty, it happened quite quick, within an hour from 1/2 tank to need to refuel, so refuelled full tank, now shows totally empty, nothing there and stays like that, no change.

Audi dealer says fuel sender not working, need to replace fuel pump!!!, why is this?

cheers

krish
I had the same problem in my 05 4.2. At least in the states Audi issued a TSB for 05 and 06 cars calling for a software update. If you want me to send you the TSB, which may save you the price of a fuel pump, send me a PM with your e-mail address and reference the gas gauge showing empty.
__________________
Orig Owner 05 A6 4.2 Night Blue, Platnum Voltera Lther & Wood, Nav, Prem Sound, Sirius, DVD Player, Heated F & R Seats & Steering Wheel, Ski Sack & Hdlight Washers, S8 Rims, Adv Key, Solar Sunrf, Pwr Sunshade, Rear Airbags, Parktronic, Voice Recog, TPMS, Adptv Hdlights, Pwr Adjst Steering Col, Pwr Mirrors, H&R Sway Bar, Koni FSD dampers
  #6  
Old 06-02-2009, 05:15 PM
1st Gear
 
Join Date: Jan 2008
Posts: 17
Points: 3,374, Level: 36
Points: 3,374, Level: 36 Points: 3,374, Level: 36 Points: 3,374, Level: 36
Level up: 16%, 126 Points needed
Level up: 16% Level up: 16% Level up: 16%
Daily Activity: 3.3%
Daily Activity: 3.3% Daily Activity: 3.3% Daily Activity: 3.3%
Default

Quote:
Originally Posted by Kevin View Post
I had the same problem in my 05 4.2. At least in the states Audi issued a TSB for 05 and 06 cars calling for a software update. If you want me to send you the TSB, which may save you the price of a fuel pump, send me a PM with your e-mail address and reference the gas gauge showing empty.
kevin

I don't really understand your post, I am in UK, we might have different engines
  #7  
Old 06-02-2009, 07:24 PM
2nd Gear
 
Join Date: Jan 2005
Location:
Posts: 1,373
Points: 7,096, Level: 55
Points: 7,096, Level: 55 Points: 7,096, Level: 55 Points: 7,096, Level: 55
Level up: 73%, 54 Points needed
Level up: 73% Level up: 73% Level up: 73%
Daily Activity: 5.1%
Daily Activity: 5.1% Daily Activity: 5.1% Daily Activity: 5.1%
Default

Quote:
Originally Posted by krishcanag View Post
kevin

I don't really understand your post, I am in UK, we might have different engines
In the states the fuel gauge reading a false empty is common in the 2005 and 2006 cars. It turned out that the false reading was caused by a software issue, not the fuel pump. Audi issued a Technical Service Bulletin (TSB) on how to upgrade the fuel gauge software to fix the problem. It was done to my car, a 2005 4.2, a couple of years ago. I don't know if Audi had the same software problem in the UK.
__________________
Orig Owner 05 A6 4.2 Night Blue, Platnum Voltera Lther & Wood, Nav, Prem Sound, Sirius, DVD Player, Heated F & R Seats & Steering Wheel, Ski Sack & Hdlight Washers, S8 Rims, Adv Key, Solar Sunrf, Pwr Sunshade, Rear Airbags, Parktronic, Voice Recog, TPMS, Adptv Hdlights, Pwr Adjst Steering Col, Pwr Mirrors, H&R Sway Bar, Koni FSD dampers
  #8  
Old 06-05-2009, 04:09 AM
1st Gear
 
Join Date: Jan 2008
Posts: 17
Points: 3,374, Level: 36
Points: 3,374, Level: 36 Points: 3,374, Level: 36 Points: 3,374, Level: 36
Level up: 16%, 126 Points needed
Level up: 16% Level up: 16% Level up: 16%
Daily Activity: 3.3%
Daily Activity: 3.3% Daily Activity: 3.3% Daily Activity: 3.3%
Default

For unknown reason, the fuel guage has started working again, after I re-filled the tank full again. Its been a couple of days and it is as normal, I am waiting for it to get to around 1/3 full when it last suddenly went down fast. I guess it still could be a problem with the fuel sender?
krishan
  #9  
Old 11-29-2009, 10:30 AM
1st Gear

 
Join Date: Apr 2009
Posts: 5
Points: 3,041, Level: 33
Points: 3,041, Level: 33 Points: 3,041, Level: 33 Points: 3,041, Level: 33
Level up: 94%, 9 Points needed
Level up: 94% Level up: 94% Level up: 94%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default

Same thing happened last night. Earlier in the day I backed the car out of the garage and parked it on an incline with the rear going downhill - no dash warning. About 10 hours later, started it up and immediately got a dash warning SERVICE with gas tank icon, fuel gauge on E, and miles left ZERO. After parking the car on level surface overnight gauge went to normal the next morning.
As with PO, there was approx. 1/3 tank of gas.
  #10  
Old 07-06-2010, 03:59 AM
Junior Member
 
Join Date: Jul 2010
Posts: 1
Default

Quote:
Originally Posted by Kevin View Post
In the states the fuel gauge reading a false empty is common in the 2005 and 2006 cars. It turned out that the false reading was caused by a software issue, not the fuel pump. Audi issued a Technical Service Bulletin (TSB) on how to upgrade the fuel gauge software to fix the problem. It was done to my car, a 2005 4.2, a couple of years ago. I don't know if Audi had the same software problem in the UK.
Hello Kevin, I have an Audi A6 2006 2.0 TDI, I had a similar fault the other day. Gauge dropped from Half to Empty. Filled the tank which was actually only half empty and is now currently showing full. Not sure if the error will still be there when it gets back down to half... Can you advise if the TSB Technical Service Bulletin was applicable to this model and could you send it me?
Old 07-06-2010, 03:59 AM
 
 
 
Reply


Tags
2009, a4, audi, elantra, empty, fuel, gas, gauge, hyundai, miles, showing, shows, tank, tt, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
New Sponsors

All times are GMT -4. The time now is 03:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.
Internet Brands, Inc.
Emails Backup