Turn signals don't work, Flashers do? - AudiForums.com
AudiForums.com

Go Back   AudiForums.com > Audi Models > Audi A4 > B5 Models
Sign in using an external account
Register Forgot Password?
Search

B5 Models Please discuss all 1996 - 2001 B5 A4 topics here...

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-01-2010, 03:43 PM
1st Gear
 
Join Date: Oct 2010
Posts: 6
Default Turn signals don't work, Flashers do?

Hey everyone,

I was hoping my first post on the forum wouldn't be regarding a problem, but I guess these things come up.


So I was driving my '98 A4 quattro avant today, and I noticed my turn signals were not working.... In trying to diagnose the problem, I checked my emergency flashers and sure enough they work all-around; outside and green arrows in the instrument panel.

Furthermore, the high beams work so that almost makes me want to rule out the stalk, but it seems more likely to be the case instead of the flasher relay seeing as they work.

But then again, I'm new to the marque. So that's why I'm here asking ya'll.

What do you guys think?
Reply With Quote
  #2  
Old 10-01-2010, 03:52 PM
jjcrt2's Avatar
1st Gear

 
Join Date: Jan 2009
Location: EPHRATA PENNSYLVANIA
Posts: 267
Send a message via AIM to jjcrt2 Send a message via Yahoo to jjcrt2
Default

my vote gos to flasher relay, just replaced mine bc i had the same problem
__________________
apr stg 2 tune, carboino cai, borla exhaust, test pipe, apr r1 dv, apr tip, ngk bkr7e plugs, h and r springs, 18x8.5 sport tunning wheels, bfg tires, tinted tails, black audi ring emblems, europlate, kennwood headunit, 2 kicker cvx 12's, vdo boost gauge
Reply With Quote
  #3  
Old 10-01-2010, 08:37 PM
Tweaked's Avatar
3rd Gear

 
Join Date: May 2008
Location: CT
Posts: 1,900
Default

Relay/hazard switch
__________________
Porsche & Audi Certified Technician
Porsche & Audi Certified Geek
Reply With Quote
  #4  
Old 10-01-2010, 08:47 PM
CCA4's Avatar
Administrator
 
Join Date: Jun 2008
Location: NW PA
Posts: 7,588
ck323k @ck323k
Send a message via AIM to CCA4
Default

I'll be the third vote for the hazard relay, circle gets the square. You're gonna need this little guy. Unfortunately I think changing that is far more difficult on a 98 than on 99.5 and up
__________________
RIP Jazz

AWM Assembly Manual PDF
Reply With Quote
  #5  
Old 10-01-2010, 09:23 PM
chocalotstarfish's Avatar
Super Moderator

 
Join Date: Dec 2009
Location: USA
Posts: 4,298
Blackstar847
Default

again on the relay! not sure of the link but there is a DIY to repair it!
__________________
Quattro-"anybody who doesn't have it is doomed to flail about on the road like a drunk old lady on roller skates."-Jim P.
Reply With Quote
  #6  
Old 10-02-2010, 11:26 AM
1st Gear
 
Join Date: Oct 2010
Posts: 6
Default

Yeah it is more difficult to get out because of the trim... Got it out in 1 piece w/ no damage though...

We'll try cleaning and maybe switching the relays as a temp fix... it's the weekend and nothing would ship out till monday anyways.

Thanks
Reply With Quote
  #7  
Old 10-02-2010, 12:34 PM
1st Gear
 
Join Date: Oct 2010
Posts: 6
Default

So it appears that My relay is completely different than the one in the DIY video. Mine isn't a 3 dimensional triangle-- and goes into the dash vertically oriented rather than horizontal.

I pulled it out and dissassembled it anyways cleaned the 7 pins which appeared a little dull.

Seems to be a completely different part than the one illustrated... So I wasn't able to try switching the two relays illustrated http://forums.audiworld.com/showthre...n+signal+blink

This is what Mine looks like

Does anybody know if the problems still pertain to these ones?
Reply With Quote
  #8  
Old 10-02-2010, 12:56 PM
CCA4's Avatar
Administrator
 
Join Date: Jun 2008
Location: NW PA
Posts: 7,588
ck323k @ck323k
Send a message via AIM to CCA4
Default

Yours is different because they changed the design of the dash and everything in it starting in 99.5. I take it cleaning yours didn't help at all?
__________________
RIP Jazz

AWM Assembly Manual PDF
Reply With Quote
  #9  
Old 10-02-2010, 01:22 PM
1st Gear
 
Join Date: Oct 2010
Posts: 6
Default

No help... at least the flashers still work after my attempt at at cleaning and everything went back together fine...

The parts for my model seem to be at least $70 everywhere I look Newer ones are all around 50 it seems
Reply With Quote
  #10  
Old 10-02-2010, 02:21 PM
chocalotstarfish's Avatar
Super Moderator

 
Join Date: Dec 2009
Location: USA
Posts: 4,298
Blackstar847
Default

vortex should have one or two floating around for like $25
__________________
Quattro-"anybody who doesn't have it is doomed to flail about on the road like a drunk old lady on roller skates."-Jim P.
Reply With Quote
  #11  
Old 10-02-2010, 02:53 PM
1st Gear
 
Join Date: Oct 2010
Posts: 6
Default

You got a link, brotha?
Reply With Quote
  #12  
Old 10-02-2010, 04:26 PM
chocalotstarfish's Avatar
Super Moderator

 
Join Date: Dec 2009
Location: USA
Posts: 4,298
Blackstar847
Default

http://forums.vwvortex.com/forumdisplay.php?529

Their site sucks monkey "D" but they have a good classifieds. Post that you want to buy one or search if anyone has a working one!
__________________
Quattro-"anybody who doesn't have it is doomed to flail about on the road like a drunk old lady on roller skates."-Jim P.
Reply With Quote
Old 10-02-2010, 04:26 PM
 
 
 
submit to reddit
Reply


Tags
2000, 2001, a4, audi, b5, blinkers, dont, emergency, flashers, signals, tt, turn, turning, wont, work


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


 

Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
Audi Custom Rims
K&N Engineering, Inc.
GetCoolParts.com
TunerDomes
Advertise here
All times are GMT -4. The time now is 01:03 AM.

Internet Brands, Inc.
Emails Backup