AudiForums.com

Go Back   AudiForums.com > Audi Models > Audi A4 > B6 Models
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Parts Search Today's Posts Mark Forums Read ExperienceGarageUsed CarsVendor Directory
Search
Welcome to AudiForums.com

B6 Models Please discuss all 2002 - 2005 B6 A4 topics here...

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-27-2011, 02:13 PM
1st Gear

 
Join Date: Mar 2011
Posts: 7
Points: 642, Level: 12
Points: 642, Level: 12 Points: 642, Level: 12 Points: 642, Level: 12
Level up: 84%, 8 Points needed
Level up: 84% Level up: 84% Level up: 84%
Daily Activity: 1.3%
Daily Activity: 1.3% Daily Activity: 1.3% Daily Activity: 1.3%
Default B6 Audi A4 - ABS + EPC + MIL Lights On - Please Advise

Hi Everyone, this is my first post on AF so please take it easy on me if i'm not following any specific format.

I have tried to search the forums for my exact issue and while there were some good "finds" there wasn't a direct solution to my problem.

Now on to what i'm "experiencing".

The check engine light, ABS, and EPC lights are on at the moment. Sometimes the EPC + ABS lights go away (when they do go away, the go away together) and the check engine light will remain . When the ABS and EPC lights come back on, the speedometer stops working ( stays at 0mph). The speedometer will work if the ABS + EPC lights are gone but the check engine is present.

I had the codes run and the first time i got this error code:
P0501 - ABS Speed sensor left front
I bought this part and replaced it.

Now all 3 lights are back and i ran the codes again:
P0501 - Vehicle Speed Sensor A - Range

The exact vehicle is 2003 Audi A4 3.0L V6 Quattro.

My initial guess is that i need to replace this part.

I thank all of you in advance for your expert assistance. This is my first audi ( love the car) but don't want to endlessly try to troubleshoot it.
  #2  
Old 01-23-2012, 10:45 AM
1st Gear
 
Join Date: Jan 2012
Posts: 2
Points: 60, Level: 1
Points: 60, Level: 1 Points: 60, Level: 1 Points: 60, Level: 1
Level up: 20%, 40 Points needed
Level up: 20% Level up: 20% Level up: 20%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default

js2724 Did you ever find any info on your problems? I'm having the same problem check engine light on, abs+epc on, and p501 vehicle speed sensor code. Same car 2003 audi a4 v6 quattro. I have replaced speed sensor inside transmission but speedo work but back out. I remember reading somewhere that all this might be a problem with ECU.
  #3  
Old 01-23-2012, 10:55 AM
1st Gear

 
Join Date: Mar 2011
Posts: 7
Points: 642, Level: 12
Points: 642, Level: 12 Points: 642, Level: 12 Points: 642, Level: 12
Level up: 84%, 8 Points needed
Level up: 84% Level up: 84% Level up: 84%
Daily Activity: 1.3%
Daily Activity: 1.3% Daily Activity: 1.3% Daily Activity: 1.3%
Default

Quote:
Originally Posted by tnsparky View Post
js2724 Did you ever find any info on your problems? I'm having the same problem check engine light on, abs+epc on, and p501 vehicle speed sensor code. Same car 2003 audi a4 v6 quattro. I have replaced speed sensor inside transmission but speedo work but back out. I remember reading somewhere that all this might be a problem with ECU.
Hi yes I finally fixed the problem. It was the abs module computer that was faulty. Check out these guys module masters (quick google search will pull them up). They offer a mail in service.

I went to so many mechanics without luck. Finally Greg over at germanautorepairs.com was able to diagnose and solve the problem for me. I highly recommend him if you are in long island, ny.

Hope this helps
  #4  
Old 01-23-2012, 11:04 AM
1st Gear
 
Join Date: Jan 2012
Posts: 2
Points: 60, Level: 1
Points: 60, Level: 1 Points: 60, Level: 1 Points: 60, Level: 1
Level up: 20%, 40 Points needed
Level up: 20% Level up: 20% Level up: 20%
Daily Activity: 0%
Daily Activity: 0% Daily Activity: 0% Daily Activity: 0%
Default

I'm in TN but mail in service would work, I will check it out. Thanks
Old 01-23-2012, 11:04 AM
 
 
 
Reply


Tags
2002, 2003, 30, a4, abs, audi, b6, change, check, diagram, engine, epc, light, mil, sensor, speed


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
New Sponsors

All times are GMT -4. The time now is 12:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.
Internet Brands, Inc.
Emails Backup