Valve Cover Gasket causing idling issues? -

Go Back > Audi Models > Audi A4 > B6 Models

B6 Models Please discuss all 2002 - 2005 B6 A4 topics here...

LinkBack Thread Tools Search this Thread
Old 05-24-2010, 03:25 PM
1st Gear
Join Date: Feb 2009
Posts: 54
Default Valve Cover Gasket causing idling issues?

Hi all,
I have been trying to tackle this ongoing issue. Rough idle with RPMs jumping to 1200 in park. P0507 :Idle Control System Higher than Expected and P0171 :Fuel Trim,Bank1 System too Lean. Checked all lines and hoses.

1) Air escaping from PCV - replaced this item and there was oil in the old one. Car runs better but CEL comes back with rough idle.

2) Clean MAF - Issue still there.

3) Now I have oil on ground!? 2-inch round diameter. Previous owner mentioned that the valve cover gasket needs to be replaced. I have just been holding it off.

Can a faulty valve cover gasket be causing all these issues? I went ahead and ordered the gasket and will be spending by sat replacing this. It better work.
Reply With Quote
Old 05-26-2010, 09:50 AM
1st Gear

Join Date: Apr 2010
Location: Windsor, Connecticut
Posts: 163
Benjamin Nash A4kid02
Send a message via Skype™ to 02A4kid

idk but i just did the valve cover gasket in my 02 a4 1.8T this morning, now previously my car sounded like a deisel and i was watching the oil drop off from the gasket straight onto the cat and now that ive replaced it it sounds a lot quieter but my problems still persist....but i dont think that your issues are coming from the valve cover gasket. my engine also starts out around 1200 rpm and after a minute or so slowly crawls back down to 800 so idk how to interpret that at the moment..
Reply With Quote
Old 05-26-2010, 06:29 PM
Former Sponsor
Join Date: Feb 2010
Location: Baltimore, MD
Posts: 358
Send a message via AIM to R.A.I. Motorsport

Valve cover won't really cause idling issues unless its a massive leak. First I would check for vacuum leaks. Then I would check the plugs/coilpacks/MAF/02 sensor.
Reply With Quote
Old 05-27-2010, 01:49 PM
1st Gear
Join Date: Feb 2009
Posts: 54

Thanks guys. Any luck 02A4? Having the same problems. Start up car, idles at 1200 then when I put it in drive goes down to 800.

I'll still replace the valve cover gasket to at least stop the oil but I think my issue will still be there. After this and checking the lines again for leaks, I might have to head over to a mechanic, don't want to spend my 3-day weekend working on my car...
Reply With Quote
Old 06-01-2010, 04:34 PM
1st Gear
Join Date: Feb 2009
Posts: 54

Update: Replaced Valve Cover Gasket (stupid small hose to the left added about an hour to this project, couldn't remove the cover as easily as I thought).

Oil drip is fixed, high RPM is still there at idle aahhh.

Removed MAF cable and car is running the same so the MAF is not the issue.

Im pretty sure its a leak somewhere. Off to my buddy's shop to see if he can help/locate leak.
Reply With Quote
Old 06-09-2010, 01:46 AM
1st Gear
Join Date: Feb 2009
Posts: 54

It was a crack in the breather hose behind intake (crank case vent system). Talked to dealer and they say they replace that everyday on audis. They wanted $1300 to replace it because they needed to heat the hoses together or some bs, went somewhere else for a fraction of cost.

Problem fixed and codes gone, ...for now.

Last edited by audiblacky; 06-09-2010 at 01:51 AM.
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Valve Cover Gasket Issues Chris2525 B5 Models 7 08-26-2014 09:05 PM
"New" Valve Cover Gasket Issues? cekren B5 Models 3 07-22-2014 02:06 AM
Help! Valve Cover Gasket & Cam Tensioner Gasket Replacement robert.jones Audi A6 1 12-10-2008 09:01 AM
Help! Valve Cover Gasket & Cam Tensioner Gasket Replacement robert.jones General Tech 1 12-10-2008 08:56 AM
Combo valve is causing performance issues nero117amx Audi TT 3 07-16-2007 02:57 PM

audi, b6, case, caused, cover, crankcase, faulty, gasket, gaskets, idle, issues, regauaor, replaced, rough, seal, valve, vavle

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 10:45 PM.