Go Back  AudiForums.com > Audi Models > Audi A8
Audi a8 97 won't start ! Please advise >

Audi a8 97 won't start ! Please advise

Audi A8 This full sized Audi A8 sedan offers interior luxury and spaciousness comparable to any car in the full sized luxury sedan class

Audi a8 97 won't start ! Please advise

  #1  
Old 11-05-2009, 03:58 PM
1st Gear
Thread Starter
Join Date: Nov 2009
Posts: 8
Default Audi a8 97 won't start ! Please advise

Hello, I have audi a8 97 4.2 v8 112K MILES , short history of the vehicle : First I had problems with brakes no matter i changed all 4 discs and pads, than it started to have problems with transmission, it stalled always at around 40-50mph, and finally wont start any more ... I pulled up the codes and I got these CODES


for Engine DTC:


18010- Power Supply (B+) Terminal 30-Low Voltage

17915 - Idle Sys.Learned Value Lower Limit Attained

17925- Main Relay (J271): Electrical Malfunction

17609 - Cylinder # 1 - Fuel Injector Circuit - Electrical Malfunction

17613 - Cylinder # 5 - Fuel Injector Circuit - Electrical Malfunction

17612 - Cylinder # 4 - Fuel Injector Circuit - Electrical Malfunction

17616 - Cylinder # 8 - Fuel Injector Circuit - Electrical Malfunction

17817 - Tank Ventilation Valve - Electrical Malfunction

17917 - IAC- Circuit Electrical Malfunction

16505 - Throttle Position Sensor A- Circuit Performance Problem- Out of Range


A/T DTC 3 CODES :

18258- Powertrain Data Bus: Missing Message from ECU

18264-Throttle/Pedal Pos.Sensor A Circ. Error Message from Engine Contr.

17087-Brake Switch (F): Electrical Malfunction


I have recharged and checked the battery , replaced Throtlle Position Sensor , cleaned IAC . I checked the codes again and now Codes : 17817 - Tank Ventilation Valve - Electrical Malfunction ,17917 - IAC- Circuit Electrical Malfunction ;16505 - Throttle Position Sensor A- Circuit Performance Problem- Out of Range DOES NOT APPEAR NO MORE . I still have other 10 codes :


Engine DTC 7 CODES:

18010- Power Supply (B+) Terminal 30-Low Voltage

17915 - Idle Sys.Learned Value Lower Limit Attained

17925- Main Relay (J271): Electrical Malfunction

17609 - Cylinder # 1 - Fuel Injector Circuit - Electrical Malfunction

17613 - Cylinder # 5 - Fuel Injector Circuit - Electrical Malfunction

17612 - Cylinder # 4 - Fuel Injector Circuit - Electrical Malfunction

17616 - Cylinder # 8 - Fuel Injector Circuit - Electrical Malfunction

A/T DTC 3 CODES :

18258- Powertrain Data Bus: Missing Message from ECU

18264-Throttle/Pedal Pos.Sensor A Circ. Error Message from Engine Contr.

17087-Brake Switch (F): Electrical Malfunction


Car wont even crank now it acts like for example immobilizer is on or something , when I turn the key on everything works , lights, fan ... and when I try to turn car on nothing happens .. Its interesting that there are no ABS CODES and car is not breaking at all ?! Any suggestions ? Thank you very much !
 
  #2  
Old 11-09-2009, 06:08 AM
Member
Join Date: Nov 2008
Location: Zagreb, Croatia
Posts: 77
Default

did you try to take ECU to shop for testing?
did you had any short circuit on installation?

it seems that you have electrical problems , especially in connection..
 
  #3  
Old 11-10-2009, 08:37 PM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

Your problem seems to lye with the main relay J271, which i believe is the fuel pump relay, I would start there.
 
  #4  
Old 11-10-2009, 11:08 PM
1st Gear
Thread Starter
Join Date: Nov 2009
Posts: 8
Default close to solution

Thank you very much for trying ! Most of the codes were there beacause of bad battery and immobilizer , after I replaced baterry and put the code in the radio only code for Maf Sensor appeared ,I changed Maf today and I replaced main relay and TPS few days ago . Finally NO CODES !!! Now car starts for 10 seconds and than dies , I left screws on TPS loose and I am trying to get TPS in position where car will work normal but no luck . The old TPS was marhe with Yellow color where was positioned on the throtlle body but that postion is probably not the same on New TPS . Bottom line I NEED HELP adjusting new TPS so that that cars works normal
 
  #5  
Old 11-11-2009, 12:29 AM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

It has to be set electrically with the vag com, there is a DIY on how to do it on www.ross-tech.com
 
  #6  
Old 11-11-2009, 11:30 AM
1st Gear
Thread Starter
Join Date: Nov 2009
Posts: 8
Default

Can you please send me the page for TPS adjustment cause I was trying to find instructions how to do it but I couldn't find them
Many thanks !
 
  #7  
Old 11-12-2009, 12:22 AM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

http://www.ross-tech.com/vag-com/cars/throttlebody.html

Took all of about 5 seconds, google rules.
 
  #8  
Old 11-12-2009, 05:10 AM
1st Gear
Thread Starter
Join Date: Nov 2009
Posts: 8
Default

Throttle Body Alignment
Updated 29 Jan. 2007

Ross-Tech is not responsible for any damage or problems that may result from following these instructions. They are to be used at your own risk. As always, you should refer to a Factory Repair Manual for your vehicle!

This procedure details how to perform a Throttle Body Alignment (TBA) on many VW/Audi vehicles. This procedure cycles the motorized throttle body through various states (idle, part throttle, WOT) to relearn their positions. Some examples of reasons to perform a TBA:

*

The vehicle's battery has been disconnected and re-connected (*MY CASE)
*

The ECU has been removed and reinstalled
*

The Throttle Body has been cleaned or removed and reinstalled (*MY CASE)
*

The Accelerator Pedal has been removed and reinstalled

In some vehicles, the car will not run correctly, or may not run at all without performing a TBA after one of the above operations. The TBA can be performed on both Drive-By-Wire (DBW or E-gas) as well as Cable-throttle cars as long as there is no Idle Stabilization Valve (ISV). If there is an ISV, then there is no motorized control of the throttle at all. Typically, '96-'99 VW/Audi have motorized Cable-throttle, and '00+ VW/Audi have DBW. Obviously, there are some exceptions. This should be obvious but TDI's do not have throttle bodies.


First, thank you so much for helping! My car is 97 Audi A8 with Idle Stabilization Valve (ISV) on the top of the Throttle Body, so which category am I ? :

1. ''If there is an ISV, then there is no motorized control of the throttle at all.'' ?
OR
2." Typically, '96-'99 VW/Audi have motorized Cable-throttle" ?

If my car has this '' motorized Cable -Throttle '' should I tighten the screws on TPS before I perform Throttle Body Alignment and in which position should I live TPS, the one that the old TPS was or ?

Than I just need somehow to get my Ebay interface to work with Vag-com and with a little help from my Audi friends I should be soon on ''back on the road'' status
 
  #9  
Old 11-12-2009, 03:28 PM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

It covers all audis pretty much after the early 90's, trust me it covers you. It doesn't matter if you have a throttle cable, the ECM still reads the distance (voltage) that the throttle is open.
If you're having problems with your EBAY cable communicating chances are it won't work. You need to actually buy the cable from ross-tech.
 
  #10  
Old 11-12-2009, 06:42 PM
1st Gear
Thread Starter
Join Date: Nov 2009
Posts: 8
Default

Great ! I finally got cenected Ebay interface with Vag-COM, now which one of these 3 procedures should I use ?

Procedure for performing a Throttle Body Alignment on Cable-Throttle Cars:
These are cars with a physical cable between the accelerator and the throttle, but WITHOUT an ISV.

Turn the key on but do not start the car.

[Select]
[01 - Engine]
[Measuring Blocks - 08]
Group 098 (Note: Some SIMOS or Marelli ECU's use Group 001 such as ADY & AEE engines)
[Go!]
[Switch to basic settings]
Once you do this you will see the top right display say ADP RUN. The TB adaptation is being done as soon as you switch to basic settings. You will see the values change and hear the TB cycle for the first few seconds then it will stop. Leave it in Basic Settings for about 30 seconds.
[Switch to Meas. Blocks] button and you're all set.

Be sure not to touch the accelerator and make sure the engine is NOT running when you do this!

Procedure for performing a Throttle Body Alignment on DBW Cars using KWP-1281:
(Check to see if the engine speaks KWP-1281 by looking in the top left of the Open Controller Screen Some examples of KWP-1281 engine controllers are 2000+ Golf/GTI/Jetta/New Beetle/Audit TT 1.8T)

Turn the key on but do not start the car.

[Select]
[01 - Engine]
[Measuring Blocks - 08]
Group 060
[Go!]
[Switch to basic settings]
Once you do this you will see the top right display say ADP RUN. The TB adaptation is being done as soon as you switch to basic settings. You will see the values change and hear the TB cycle for the first few seconds then it will stop. Leave it in Basic Settings for about 30 seconds.
[Switch to Meas. Blocks] button and you're all set.

Be sure not to touch the accelerator and make sure the engine is NOT running when you do this!

Procedure for performing a Throttle Body Alignment on DBW Cars using KWP-2089:
(Check to see if the engine speaks KWP- 2089 by looking in the top left of the Open Controller Screen Some examples of KWP-2089 engine controllers are 2002+ Audi A4, 2002+ VW Passat, and Touareg)

Turn the key on but do not start the car.

[Select]
[01 - Engine]
[Basic Settings - 04]
Group 060
[Go!]
It should say "Basic Settings: OFF" on the top of your screen.
Click [ON/OFF/Next] to turn on Basic Settings.
It should now say "Basic Settings: ON" on the top of your screen.
Once you do this you will see the top right display say ADP RUN. The TB adaptation is being done as soon as you switched basic settings on. You will see the values change and hear the TB cycle for the first few seconds then it will stop. Leave it in Basic Settings for about 30 seconds.
Click [ON/OFF/Next] to turn off Basic Settings.
It should now say "Basic Settings: OFF" on the top of your screen
Click the [Done, Go Back] button and you're all set.

Be sure not to touch the accelerator and make sure the engine is NOT running when you do this!

And should I tighten the screws on TPS before this procedure and on which position to put TPS ?
 

Thread Tools
Search this Thread
Quick Reply: Audi a8 97 won't start ! Please advise


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.