Electronics Wired up? Everyone's got some sort of electrical modification. let's hear about it here.

Oil Pressure warning issues

  #1  
Old 01-28-2017, 12:25 PM
1st Gear
Thread Starter
Join Date: Jan 2017
Posts: 2
Exclamation Oil Pressure warning issues

I have a 2007 Audi A4 2.0T. Recently I have had an issue arise where my "Oil Pressure" warning light comes on when the engine reaches 2k RPM. I replaced the oil filter still the warning appeared. Tested the oil pressure switch and that was bad so I replaced it. Interestingly enough I still get the warning light. Tested the switch again and the new one was fine, checked the screen on the pump in the oil pan and it is clear. I finally gave up and took it to the dealership and they tested the pressure and the oil pressure is good. The switch is good, filter good, pump good, they checked the wiring that's good too. SO! Where the heck is this warning light coming from? The Dealer says, "it may be the instrument cluster is bad and is not reading the signal correctly." Just wondering with anybody else thinks. I don't want to drop a ton of money into an instrument cluster if that's not the issue.
 
  #2  
Old 02-27-2017, 08:39 PM
4Rings's Avatar
1st Gear
Join Date: Oct 2005
Location: Ontario CA USA
Posts: 17
Default

Originally Posted by UTL098 View Post
I have a 2007 Audi A4 2.0T. Recently I have had an issue arise where my "Oil Pressure" warning light comes on when the engine reaches 2k RPM. I replaced the oil filter still the warning appeared. Tested the oil pressure switch and that was bad so I replaced it. Interestingly enough I still get the warning light. Tested the switch again and the new one was fine, checked the screen on the pump in the oil pan and it is clear. I finally gave up and took it to the dealership and they tested the pressure and the oil pressure is good. The switch is good, filter good, pump good, they checked the wiring that's good too. SO! Where the heck is this warning light coming from? The Dealer says, "it may be the instrument cluster is bad and is not reading the signal correctly." Just wondering with anybody else thinks. I don't want to drop a ton of money into an instrument cluster if that's not the issue.

If the dealership tested your oil pressure and is ok, you don't have any problems.
What I'd do is replace the pressure sending unit. It'll run you under $20.00
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
colinst205wrc
B6 Models
1
11-19-2013 06:30 AM
Dallas09
B5 Models
2
08-30-2011 05:57 PM
hypnos
Audi A6
4
01-08-2008 08:53 AM


Thread Tools
Search this Thread
Quick Reply: Oil Pressure warning issues


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.