Go Back  AudiForums.com > Audi Tech > General Tech
Trouble with transmission P0706 >

Trouble with transmission P0706

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Trouble with transmission P0706

  #1  
Old 07-25-2016, 03:39 PM
1st Gear
Thread Starter
Join Date: Jul 2016
Posts: 2
Default Trouble with transmission P0706

Hi Everyone,
I have a B7 2006 Audi A4 (CVT transmission). I have had my PRNDS flashing for quite some time now. Due to transmission range sensor code being active (P0706) I understand that the TCM is bad and needs to be rebuilt/replaced. What I need help with is understanding if my actual transmission is damaged, and if it is worth fixing the sensor.
Symptoms:
-Between 1700 and 2000 RPM, the RPM needle pulses and the car jerks, regardless of the speed/gear.
-for the above reason, I try driving in triptronic mode and keep RPMs over 2000, with minimal issues but now it is showing some signs of the below issue in triptronic as well.
-more recently, the RPMs will go up gradually to 3k then 4k but the acceleration does not increase with the RPMs, which is unusual (mostly in Drive, and sometimes in triptronic mode now)
-Triptronic gear shifting is generally smooth except for when i switch between second and third gear, at that point the car jerks a bit
-also more recently the turbo no longer engages
-Sometimes the reverse does not engage

Also the following codes appeared:
P1624-MIL Request Signal Active (Check TCM for errors tool) - Intermittent
P2293-Fule Pressure Regulator Valve (N276) - Mechanical Malfunction - MIL ON
P0087-Fuel Rail/System Pressure - Too low - intermittent
P310B-Low Pressure Fuel regulation - Fuel pressure outside specification - intermittent
P1602-Power Supply Terminal 30 - Voltage too low - intermittent

I should add that my head cover gasket is leaking. I have had to replace ignition coils and spark plugs in the past. I will fix the problem, once I figure out the transmission issue.

Any help will be appreciated.
 

Last edited by ProlificScarcity; 07-25-2016 at 04:22 PM.
  #2  
Old 11-03-2016, 10:31 AM
1st Gear
Join Date: Nov 2016
Posts: 4
Default

Originally Posted by ProlificScarcity View Post
Hi Everyone,
I have a B7 2006 Audi A4 (CVT transmission). I have had my PRNDS flashing for quite some time now. Due to transmission range sensor code being active (P0706) I understand that the TCM is bad and needs to be rebuilt/replaced. What I need help with is understanding if my actual transmission is damaged, and if it is worth fixing the sensor.
Symptoms:
-Between 1700 and 2000 RPM, the RPM needle pulses and the car jerks, regardless of the speed/gear.
-for the above reason, I try driving in triptronic mode and keep RPMs over 2000, with minimal issues but now it is showing some signs of the below issue in triptronic as well.
-more recently, the RPMs will go up gradually to 3k then 4k but the acceleration does not increase with the RPMs, which is unusual (mostly in Drive, and sometimes in triptronic mode now)
-Triptronic gear shifting is generally smooth except for when i switch between second and third gear, at that point the car jerks a bit
-also more recently the turbo no longer engages
-Sometimes the reverse does not engage

Also the following codes appeared:
P1624-MIL Request Signal Active (Check TCM for errors tool) - Intermittent
P2293-Fule Pressure Regulator Valve (N276) - Mechanical Malfunction - MIL ON
P0087-Fuel Rail/System Pressure - Too low - intermittent
P310B-Low Pressure Fuel regulation - Fuel pressure outside specification - intermittent
P1602-Power Supply Terminal 30 - Voltage too low - intermittent

I should add that my head cover gasket is leaking. I have had to replace ignition coils and spark plugs in the past. I will fix the problem, once I figure out the transmission issue.

Any help will be appreciated.
If you contact Audi and tell them about the issue and let them know that after looking up the issue online you saw that it was a very common issue they will notate it and if they hear enough people calling it in they will make a recall and fix the issue.
 
  #3  
Old 11-09-2016, 02:35 PM
1st Gear
Thread Starter
Join Date: Jul 2016
Posts: 2
Default

Originally Posted by Madelineff View Post
If you contact Audi and tell them about the issue and let them know that after looking up the issue online you saw that it was a very common issue they will notate it and if they hear enough people calling it in they will make a recall and fix the issue.
I think Audi already knows about this issue and they will cover it for a maximum of 100K as far as I have read on the forums.
 
  #4  
Old 04-10-2019, 03:32 PM
1st Gear
Join Date: Apr 2019
Posts: 1
Default

Originally Posted by ProlificScarcity View Post
Hi Everyone,
I have a B7 2006 Audi A4 (CVT transmission). I have had my PRNDS flashing for quite some time now. Due to transmission range sensor code being active (P0706) I understand that the TCM is bad and needs to be rebuilt/replaced. What I need help with is understanding if my actual transmission is damaged, and if it is worth fixing the sensor.
Symptoms:
-Between 1700 and 2000 RPM, the RPM needle pulses and the car jerks, regardless of the speed/gear.
-for the above reason, I try driving in triptronic mode and keep RPMs over 2000, with minimal issues but now it is showing some signs of the below issue in triptronic as well.
-more recently, the RPMs will go up gradually to 3k then 4k but the acceleration does not increase with the RPMs, which is unusual (mostly in Drive, and sometimes in triptronic mode now)
-Triptronic gear shifting is generally smooth except for when i switch between second and third gear, at that point the car jerks a bit
-also more recently the turbo no longer engages
-Sometimes the reverse does not engage

Also the following codes appeared:
P1624-MIL Request Signal Active (Check TCM for errors tool) - Intermittent
P2293-Fule Pressure Regulator Valve (N276) - Mechanical Malfunction - MIL ON
P0087-Fuel Rail/System Pressure - Too low - intermittent
P310B-Low Pressure Fuel regulation - Fuel pressure outside specification - intermittent
P1602-Power Supply Terminal 30 - Voltage too low - intermittent

I should add that my head cover gasket is leaking. I have had to replace ignition coils and spark plugs in the past. I will fix the problem, once I figure out the transmission issue.

Any help will be appreciated.
Did you ever replace the tcm and did it work ? Iím having the exact same issue with my 06 2.0T and the new one cost just under 2 grand so I want to make sure what my problem is before I do anything it sucks to because i got the car in Alabama at my moms and now I have to get back to work so I guess Iím just going to drive the 500 miles like it is and hope for the best , just have to keep it above 2 grand or at 1500 or below and it runs fine but for how long is the question . Let me know how it went for you so I can decide if I should put the money in it or just cut my losses now.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Cuda66
B6 Models
31
07-17-2013 12:20 AM
crissycut
B6 Models
19
07-31-2012 08:29 AM
kbayern
B6 Models
1
04-26-2011 03:36 PM
singletrac
B6 Models
0
09-10-2009 06:50 PM
kakashisan
Audi A4
1
12-24-2007 03:21 PM


Thread Tools
Search this Thread
Quick Reply: Trouble with transmission P0706


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.