Go Back  AudiForums.com > Audi Tech > General Tech
Whistling noise - B7 A4 2.0T CVT >

Whistling noise - B7 A4 2.0T CVT

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Whistling noise - B7 A4 2.0T CVT

  #1  
Old 03-30-2018, 03:32 PM
TBarCYa's Avatar
1st Gear
Thread Starter
Join Date: Feb 2007
Location: Homestead, FL
Posts: 33
Default Whistling noise - B7 A4 2.0T CVT

My 2009 A4 with the 2.0T and the CVT just started making a whistling noise at idle. As soon as I open the throttle it goes away but as soon as it closes, the whistle comes back. It even stays for about 10-15 seconds after the engine is shut off and occasionally I will get a CEL at idle and a code for a lean condition. I monitored the A/F ratio with Torque and it never went above 15 at idle.

The noise is definitely coming from the top of the engine, seems to be around the throttle body which I would have figured was a diverter issue but there shouldn't be any boost pressure at idle, right?

If anyone has any ideas I'd be glad to hear them because I don't know where to start.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BLRzAUDI
Audi A4
13
01-08-2011 03:10 AM
jonstick
Audi Q7
2
09-08-2007 10:20 PM
BearTrap
Audi A3
13
11-27-2006 05:04 PM
barryoy32
Audi A6
1
02-24-2006 03:33 PM
Matori1.8t
Audi A4
10
02-20-2006 02:03 PM


Thread Tools
Search this Thread
Quick Reply: Whistling noise - B7 A4 2.0T CVT


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.