Go Back  AudiForums.com > Audi Tech > Intake, Headers and Exhaust
 Just installed my grill and there is a problem.... >

Just installed my grill and there is a problem....

Intake, Headers and Exhaust Custom Exhaust? New Headers? Need Opinions on Intakes? Discuss making your ride breathe better here.
Sponsored by:
Sponsored by:

Just installed my grill and there is a problem....

  #1  
Old 07-23-2005, 01:21 PM
1st Gear
Thread Starter
Join Date: Jun 2005
Location:
Posts: 55
Default Just installed my grill and there is a problem....

I just put on my kamei style grill but there is one problem when i try to open my hood i have to wiggle it b/c the tongue doesnt really match the hole in the new grill... I'm pretty sure i installed everything right on it. Is it just b/c its a cheap grill that i bought off ebay and not the real Kamei??? My other question is i just bought the Audi Emblem (4 rings) How do i stick them on my custom grill now??? Is there a special glue i can use??? thanx
 
  #2  
Old 07-25-2005, 09:51 PM
6th Gear
Join Date: Nov 2003
Location: Columbs, Ohio
Posts: 10,684
Default RE: Just installed my grill and there is a problem....

Probably has to do with cheap parts from ebay. [&:]
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
arb
B5 Models
8
02-10-2011 03:30 PM
Munzter
B5 Models
14
04-17-2009 01:45 PM
ottoaudi
Audi A3
41
11-29-2007 09:46 PM
Amze
Audi A4
30
08-11-2007 04:46 PM
A3Night
Audi A3
12
10-23-2006 01:51 PM


Thread Tools
Search this Thread
Quick Reply: Just installed my grill and there is a problem....


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.