problems with my odometer

  #1  
Old 04-27-2005, 01:56 AM
1st Gear
Thread Starter
Join Date: Apr 2005
Posts: 9
Default problems with my odometer

My odo hasn't been working for a while, but the speed counter works fine. Last weekend I bought an instrument pannel from a wreakers, I installed the speedo unit into my instrument pannel, the speed counter worked but the odo didn't. To see if it was a problem with the intsrument pannel circuit board I swaped the instrument pannels - and got the same result. The instrument pannel I got from the wreakers wasn't in mint condition - the fuel and coolent temp gauges also didn't work. So I'm left with a coupe of possibilities 1) the speedo unit I got from the wreakers is also faulty or 2) that the problem lies outside the instrument pannel. I think it's probably 2.

I thought that the speedo unit simutaneously calcutaled the speed and distance travelled by recieving electrical pulses - is this correct?

Does anyone have any ideas on what the problem could be?
 
  #2  
Old 04-27-2005, 11:24 AM
2nd Gear
Join Date: Mar 2004
Location: Swamplands of NJ
Posts: 761
Default RE: problems with my odometer

Audi's did have some sort of a problem with the electronic speedometers. Go to www.sjmautotechnik.com and go through the diagnostics link, there might be a fix.
 
  #3  
Old 05-02-2005, 01:54 PM
1st Gear
Join Date: May 2005
Posts: 12
Default RE: problems with my odometer

Audibaby, I had a similar problem with my 80. Occasionally the odometer would stop, although the speedo continued to work properly. I used to zero the trip, and the odo would start up again, but it got progressively worse, and in the end was mostly out of action, and zeroing got less and less effective. I need the odo, so, like you, I acquired an instrument cluster from a scrapyard, similar mileage (165,000), and changed the speedo unit. It is now OK. This must be a common fault, so perhaps you were just unlucky with the replacement. I haven't yet checked out the site recommended by Offramp, but I hope you have success with your problem. Bryan. PS. I will be posting a problem I am experiencing, so if you have any ideas, I would like to hear them. Thanks.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ktleop1959
Audi A4
0
05-31-2015 07:27 PM
Ktleop1959
Electronics
0
05-31-2015 06:55 AM
whitecotton
B5 Models
15
08-29-2010 09:38 PM
audiprotein
Off Topic
14
02-27-2007 04:23 AM
audiprotein
Audi A4
4
02-26-2007 03:14 AM


Thread Tools
Search this Thread
Quick Reply: problems with my odometer


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.