radio won't turn on

  #1  
Old 07-05-2011, 09:23 PM
1st Gear
Thread Starter
Join Date: Jul 2011
Posts: 4
Default radio won't turn on

I just bought a 1995 audi 90 and the aftermarket radio won't turn on.I looked at the fuse for the radio under the hood and it was good.I took the radio out to test it and it powers up,any help is appreciated
 
  #2  
Old 07-30-2011, 02:01 AM
1st Gear
Join Date: Jul 2011
Posts: 3
Default

Ok, first off, just because you don't smell anything burnt does not mean that the unit is ok. More often than not, there will not be a burnt smell and there is a problem. It sounds to me as though your power amp circuit inside the radio has gone out. If it was acting sluggish before and then gave out, this is not all of a sudden, this happened over time. Im not sure what you mean when you said you pushed the face in too far, unless it rolls back into itself, then you might have broken a sensor or something of that nature. Bottom line, it will probably cost you more to get it fixed rather than to buy a new radio...Good luck.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Austin.bazuine
Electronics
0
07-27-2013 06:27 PM
Truthalive7
B6 Models
5
10-20-2011 07:41 PM
kccoon1
General Tech
3
07-05-2011 11:24 PM
Euroluv
Audi TT
3
04-02-2007 12:23 AM
badfeet
Audi A4
3
08-19-2005 06:40 PM


Thread Tools
Search this Thread
Quick Reply: radio won't turn on


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.