Go Back  AudiForums.com > Audi Models > Audi A6
04 Audi a6 2.7t bel engine codes p1118 & p1114 >

04 Audi a6 2.7t bel engine codes p1118 & p1114

Audi A6 The mid-sized Audi A6 model offers more room to the driver and passengers over the A4 line.

04 Audi a6 2.7t bel engine codes p1118 & p1114

  #1  
Old 10-28-2013, 09:31 PM
dakiddc973's Avatar
1st Gear
Thread Starter
Join Date: Sep 2013
Posts: 17
Default 04 Audi a6 2.7t bel engine codes p1118 & p1114

i Have an issue with my 2004 Audi a6 2.7t. its an automatic with a BEL engine. i have recently changed the b1 s2 sensor due to code p1118 and p1114 but they still appear. I also was i tried swiping the sensors but it still shows b1 s2 with both codes. i Cleared the codes and they constantly come back. I really need help i havent been able to drive my car for 3 months due to this becuase it wont pass inspection due to the cel for these codes.
 
  #2  
Old 10-29-2013, 05:03 AM
TwinTurboC5's Avatar
1st Gear
Join Date: May 2008
Location: South Georgia
Posts: 238
Default

If you have already replaced the O2 sensor with an OE or aftermarket direct replacement and continue to get the same error code time and time again, it may be that the sensor itself is not bad. Have you checked the connector ends? Be sure that they are free of corrosion and/or rust and check to make sure that the wiring is not frayed or cut and that the terminals withing the connectors are still tight. If you do this and then reconnect the wiring connector I would suggest using some dielectric grease on the connection.
 
  #3  
Old 10-29-2013, 10:38 PM
dakiddc973's Avatar
1st Gear
Thread Starter
Join Date: Sep 2013
Posts: 17
Default

I didnt check if the connector are fried and also i tried to see if any voltage comes out the wires and they do so i dont think the wires are cut. And i read that dielectric grease isnt good to put on connecters becuase it can short the wires and could corrode the connector wire ends themself.
 
  #4  
Old 10-31-2013, 02:54 PM
dakiddc973's Avatar
1st Gear
Thread Starter
Join Date: Sep 2013
Posts: 17
Default

I am gonna get the ecu chipped so it wont show the rear 02 sensors. That was suggested from the guys at euro performance in clifton, nj. I am just wondering if it will pass inspection like that. Any ideas on that???
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
audirpm
B5 Models
0
06-13-2008 07:36 PM
Danwilliambiba
General Tech
3
12-25-2007 09:13 AM
CRAFTSMAN_69
Audi A4
0
08-03-2007 03:53 PM
mikehh
Audi A4
3
03-02-2006 04:16 PM
mikehh
Audi A6
3
03-02-2006 10:30 AM


Thread Tools
Search this Thread
Quick Reply: 04 Audi a6 2.7t bel engine codes p1118 & p1114


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.