Go Back  AudiForums.com > Audi Models > Audi A6
 A6 4.2 with 140k trans acting funny >

A6 4.2 with 140k trans acting funny

Audi A6 The mid-sized Audi A6 model offers more room to the driver and passengers over the A4 line.

A6 4.2 with 140k trans acting funny

  #1  
Old 12-20-2007, 02:46 PM
1st Gear
Thread Starter
Join Date: Dec 2007
Posts: 9
Default A6 4.2 with 140k trans acting funny

Hello everyone,

My wonderfull 4.2 is starting tosurgebetween 4th and of 5th gear while driving at 45mph.The tach goes from 1500 to 2000 like a heartbeat. It alsoclunks downshifting to 1st at stoplights. I love the carand want to keep it, should I try a flush?

This you guys have helped me many times thank you!
 
  #2  
Old 12-20-2007, 03:18 PM
Senior Member
Join Date: Nov 2007
Location:
Posts: 282
Default RE: A6 4.2 with 140k trans acting funny

My 2.7 did this. I had it flushed and the problem didn't really go away. I talked to the dealer and they "flashed" the cumputer. No clue what flashing the computer involves but the problem went away. This isn't much but I hope it helps.
 
  #3  
Old 12-20-2007, 04:48 PM
1st Gear
Join Date: Aug 2006
Posts: 34
Default RE: A6 4.2 with 140k trans acting funny

how long have you had the A6? I'm curious to know what repairs you've made because mine has 70K and I'm wondering what to expect from it.
 
  #4  
Old 12-21-2007, 04:16 PM
Senior Member
Join Date: Nov 2007
Location:
Posts: 282
Default RE: A6 4.2 with 140k trans acting funny

ORIGINAL: namymark

how long have you had the A6? I'm curious to know what repairs you've made because mine has 70K and I'm wondering what to expect from it.
I bought the 4.2 new. Never had any real problems. The latest problem is a small coolant leak that I'm trying to find out where it's coming from. About a cup of coolant a week and it hasn't prevented me from driving it. I got the 2.7 this year (in mid July). I've done a lot of minor repairs (hazard switch, rear view mirror switch, HID headlights, aux cooling water pump, tires, all new struts, trans flush). When I bought it, I knew that it needed most of this stuff. It runs great. I bought it from a guy in Memphis (sight unseen) and drove it back to Illinois without any problems. I bought it because I wanted to get into "mods" and the price I paid was riduculous ($9500).
 
  #5  
Old 01-11-2008, 09:59 AM
1st Gear
Thread Starter
Join Date: Dec 2007
Posts: 9
Default RE: A6 4.2 with 140k trans acting funny

Thank you!
 
  #6  
Old 01-11-2008, 10:02 AM
1st Gear
Thread Starter
Join Date: Dec 2007
Posts: 9
Default RE: A6 4.2 with 140k trans acting funny

Thank you for the help! i wont waste my time I think I will live with it if it is not mechanical, was the flash expensive?
 
  #7  
Old 01-11-2008, 10:04 AM
1st Gear
Thread Starter
Join Date: Dec 2007
Posts: 9
Default RE: A6 4.2 with 140k trans acting funny

If you were asking about my car with 140k on it I purchased it out of CA so it had never seen MI winters still looks new underneath with no relating muffler rot. I have not done any major repairs only the window fix and I replaced all the front end parts as it wore out a brand new set of tires in 6 mo. It was taking the inside edges off!! I just found last nite the rack has a small pop to it when you pull on the tire hard to the front it is stiff in the center and is not loose or wearing the tires at all so I think it is ok. Has anyone else had this problem?
 
  #8  
Old 01-11-2008, 01:21 PM
Senior Member
Join Date: Nov 2007
Location:
Posts: 282
Default RE: A6 4.2 with 140k trans acting funny

ORIGINAL: kwmcfp

Thank you for the help! i wont waste my time I think I will live with it if it is not mechanical, was the flash expensive?
I'll have to find out for you. They did this for me when they did my trans flush. The Flush itself was $75.00.
 
  #9  
Old 01-11-2008, 03:51 PM
3rd Gear
Join Date: Sep 2004
Location: Newfields NH
Posts: 2,371
Default RE: A6 4.2 with 140k trans acting funny

Make sure they use the correct fluid ----I know a few Audi owners that were sorry.....
 
  #10  
Old 01-14-2008, 12:13 PM
2nd Gear
Join Date: Jan 2008
Posts: 905
Default RE: A6 4.2 with 140k trans acting funny

if your trans hasnt been flushed multiple times during its life it is BAD to flush it at 140 because is will blow apart and everything will become looser ... not recommended ... the bench flash might work tho... not sure how tho lol maybe reset something lazy ... also coudl change the shift code or get a chip to put it back in its place ... 140k on a v8 trans is pretty good ... cross your fingers for no rebuilt !!
 

Thread Tools
Search this Thread
Quick Reply: A6 4.2 with 140k trans acting funny


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.