1995 90S AC Display not working

  #1  
Old 10-02-2011, 07:15 PM
1st Gear
Thread Starter
Join Date: Feb 2010
Posts: 4
Default 1995 90S AC Display not working

So my AC Display has been going on and off for a while, and with the display goes the air. I figured it must have been a relay problem. When I popped the hood and checked the relays, I noticed that the AC relay isn't even there. I don't think it's magically disappeared in the last few days, so it's never been there. The fuses are all fine. I just moved to Arizona and my Windows stopped working (intermittent relay) about a month ago. I figured it might be connected, but I'm not certain. Every fuse under the hood is fine.

Is the AC relay supposed to be there, or is there anything else I should check? I need windows or AC to be working, both would be awesome, but at least one is necessary.

Thanks.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jonnywill
Audi Q7
15
09-07-2015 07:38 PM
rolnl
Electronics
3
09-23-2014 08:30 AM
blakemichaelson
Audi A6
0
08-19-2014 11:45 PM
aarontbrooksjr
B5 Models
0
11-15-2010 08:17 AM
mkppk
Classic Audi
4
10-16-2009 11:19 PM


Thread Tools
Search this Thread
Quick Reply: 1995 90S AC Display not working


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.