Audi 80 Trans issue, please help...

  #1  
Old 01-19-2012, 06:58 AM
1st Gear
Thread Starter
Join Date: Jan 2012
Location: Australia
Posts: 1
Default Audi 80 Trans issue, please help...

Ive got a 94 audi 80 and Ive had this issue with the trans. Basically I'd be driving along above 45 and the car will jump out of 4th and go into 3rd and 2nd, or it will simply go into limp (3rd gear). If i turn off the engine and re-start, the problem goes away but can re-occur at any time but tends to occur at high speeds and more so on inclines.

I took it to a trans specialist who said it was a hydraulic issue with the trans, so we replaced it with a 2nd hand box. The day i picked it up from the shop it did it again. I then spent the next month chasing the workshop to tell me whats wrong with it but they didnt seem to know whats going on. They basically said it could be anything and to find out what it was basically id have to fork out the money to track it.

After staying on their butts they said it could be the trans ecu, so i changed that, and still the problem persists. They then said it could be a wiring fault, so i took apart half the dash and tracked the wiring out of the trans box and up into the cabin and found 1 junction, so i made sure all the connections were tight (as best i could anyway).

When the car is hooked up to a scantool, the error codes thrown are mainly 2, a speed sensor intermittent fault and a gear monitoring intermittent fault. Ive replaced the speed sensor (well 1 of them, i hear there are 2 in this trans...) and i find it hard to believe that 2 transmissions have EXACTLY the same fault, so im assuming its not the new trans box. If the error codes are cleared then the speed sensor fault keeps popping up again and only after a few times of going into limp mode will the gear monitoring fault come up, so i think its just picking up that the gear box is jumping gears when it shouldnt rather than it being an actual fault.

Im reaaaalllly at a loss as to what to do and if ANYONE has any ideas or suggestions, please let me know. Any help would be greatly appreciated.

Thanks in advance...
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
02A4q
B6 Models
1
11-10-2014 02:47 PM
Sm0kenFast
General Tech
0
10-07-2013 04:03 AM
Sm0kenFast
Computer & Fuel Systems
0
10-06-2013 01:28 AM
Xysche
Audi A6
4
08-23-2010 12:30 PM
MickeyD
B6 Models
2
12-02-2009 10:49 AM


Thread Tools
Search this Thread
Quick Reply: Audi 80 Trans issue, please help...


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.