Go Back  AudiForums.com > Audi Models > Audi A8
Navigation not working properly >

Navigation not working properly

Audi A8 This full sized Audi A8 sedan offers interior luxury and spaciousness comparable to any car in the full sized luxury sedan class

Navigation not working properly

  #1  
Old 12-27-2010, 12:24 PM
1st Gear
Thread Starter
Join Date: Dec 2010
Posts: 2
Default Navigation not working properly

Hello,

I currently own 2006 A8 4.2 (swb) and about few months ago I noticed that my Nav began acting up on me. First it was intermitent misreading of my location to about few miles. Now it is constantly showing that I am located 25-35 miles away from my real location. In the NAV info it shows - 0 Setelites Received.

I took it to a dealer and they quoted me $1600 to replace a NAvigation Module.

Is there any way I can get that module and replace it myself? Where is it located?
Also how can I check Antenna connection?

Unfortunately I don't have VAG-Com just now.

All feedback is strongly appreciated.

Thank you
 
  #2  
Old 12-27-2010, 01:36 PM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

You need a vag com, however it can't hurt to check the connection at the antenna, these connectors almost never come apart though. The antenna is located at the roof, it will either have a shark fin at the back of the roof, or it will be a cable that runs around the rear window. The connectors look like the square ones in this pic.
Name:  gps.jpg
Views: 197
Size:  63.7 KB
You will have to pull down the rear center headliner panel to access it.
 
  #3  
Old 12-27-2010, 07:09 PM
1st Gear
Thread Starter
Join Date: Dec 2010
Posts: 2
Default

Thanks for your quick reply Auditeck79. I ejected nav dvd and put it back in and it seems to solve the problem. At least for now. I will keep monitoring it and let you know if it helped permanently.

P.S. Tomorrow I am going to Fred Baker Audi and will complain a little for telling me that my nav unit took a **** and need to be replaced for $1600.
 
  #4  
Old 12-27-2010, 10:16 PM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

I wouldn't be all gung ho about calling out the dealer, it may yet still be a bad navigation unit. If its intermittent, its more likely that it IS the module causing the problem. So monitor it and see if it malfunctions again.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JPizano23
Audi A8
0
08-11-2012 06:21 PM
JoshM
Audi A6
1
07-19-2011 06:58 AM
falcons_eye77
Audi A4
0
09-24-2008 10:01 AM
smoovmusicdj
B5 Models
0
04-21-2008 08:51 AM
ram
Audi A4
6
01-30-2007 07:02 PM


Thread Tools
Search this Thread
Quick Reply: Navigation not working properly


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.