Go Back  AudiForums.com > Audi Models > Audi A4 > B5 Models
Odometer LCD screen no longer working.... >

Odometer LCD screen no longer working....

B5 Models Please discuss all 1996 - 2001 B5 A4 topics here...

Odometer LCD screen no longer working....

  #1  
Old 01-17-2013, 09:45 PM
1st Gear
Thread Starter
Join Date: Jul 2012
Posts: 53
Default Odometer LCD screen no longer working....

Today I was driving home and thought to myself I must be close to needing an oil change. I look up at the oil change reminder sticker on the windshield to see when it was due (by mileage). I then look down to see my current mileage and there was nothing on the LCD screen. Completely blank. Nothing there at all.

I know it was working at my last fill up on Jan 13 as I entered the mileage into my MPG app on my phone. Now I have nothing. No codes on the OBD II. No idea what the mileage is exactly...

It is dark out, cold and rainy tonight so I don't feel like fumbling out in the snow/ice covered driveway tonight to yank the battery and see if that resets it. Anyone know if it is a fuse? If so, any idea which one?

Nothing else is out on the cluster. Everything else is lit up and works. Speedo, tach, oil and battery all normal and normal backlight when lights are on. Even the temp LCD in the middle is fine. It is just the lower left Odometer/trip meter LCD that is dead. No issues driving. 98 A4 Quattro 2.8.

I do recall a wierd scenario 2 days ago when I ran to the store, parked and locked the car. I came back out to the lights blinking similar to when pressing the Hazard Light button - but the lights were flashing 3x as fast as normal Hazard Flash sequence. I thought at first my dog maybe hit the hazard button but it wasn't that. As soon as I opened the doors it stopped.

Any coincidence? Gremlins?
 

Last edited by Lynskey; 01-17-2013 at 09:48 PM.
  #2  
Old 01-17-2013, 10:38 PM
BaseDrifter's Avatar
Site Moderator/B5 Tech Guru
Join Date: Feb 2010
Location: Bay Area, CA
Posts: 1,745
Default

Sounds like you have the same problem as me. The little LCD for the odometer can be intermittent. This is not very common and there is no known solution to my knowledge.

What fixes it for me? Smacking the cluster.

When the light goes out, a smack or two will usually bring it back. It is most likely a bad connection in the cluster, you could attempt to take the cluster apart and look for the problem.

Also, even though the backlight does not work, you can still read the mileage. Park the car with the sun shining on the cluster and you should be able to read it. Might be able to see it with a flashlight or something, but I've never tried that.

Good luck.
 
  #3  
Old 01-18-2013, 07:36 AM
1st Gear
Thread Starter
Join Date: Jul 2012
Posts: 53
Default

I will give the cluster beating a try. It was at night when I lost it (or noteced it lost) so I wasnt able to see very much. Thanks for the heads up.
 
  #4  
Old 01-18-2013, 06:53 PM
1st Gear
Thread Starter
Join Date: Jul 2012
Posts: 53
Default

A good slap on the dashboard and it came back. I wish everything could get the Fonz and work right... Thanks for the heads up.
 
  #5  
Old 01-18-2013, 06:58 PM
BaseDrifter's Avatar
Site Moderator/B5 Tech Guru
Join Date: Feb 2010
Location: Bay Area, CA
Posts: 1,745
Default

Glad that works for you too.

I'm just about done with a cluster swap, hopefully the new cluster doesn't have the same issue.
 
  #6  
Old 01-18-2013, 08:25 PM
1st Gear
Join Date: Sep 2010
Location: Shrewbury Massachusetts
Posts: 244
Default

Theres a dash bulb behind that LCD, when it blows the LCD goes blank. Happened to my sons car last year, pulled the cluster replaced the bulb and all is well again. Don't exactly know how the bulb works with the LCD but it does.
 
  #7  
Old 05-10-2014, 11:43 AM
diglev's Avatar
1st Gear
Join Date: May 2014
Posts: 1
Default

lost my odo reading ..knuckle punch on display sorted...
still got probs with my ignition....us had recall not here in uk...same prob as they have in us
 
  #8  
Old 05-13-2014, 11:13 AM
McGovs2.7TB5's Avatar
3rd Gear
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 1,950
Default

Did you turn it off? The button on the underside of the wiper stalk if pressed can turn the screen off as well as cycle thru the different screens.
 
  #9  
Old 03-01-2019, 10:38 AM
1st Gear
Join Date: Dec 2017
Posts: 1
Default

Originally Posted by Mark C View Post
Theres a dash bulb behind that LCD, when it blows the LCD goes blank. Happened to my sons car last year, pulled the cluster replaced the bulb and all is well again. Don't exactly know how the bulb works with the LCD but it does.
l have a 1997 A4 B5 and the odometer has done the same thing so l will try to get the replacement bulb from Audi Melbourne. l hope that its the bulb and not the cluster for it's a big job to replace the cluster even though all other lights bells and whistles are working as l want to get the right mileage on the cluster. I have noticed that when one shines a torch on to it l can read the kilometers done. Thanks for the heads up.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PFCFRANKIEA4
B5 Models
15
08-13-2011 02:27 AM
Captain Quattro
General Tech
4
03-03-2011 04:55 AM
njsully
B6 Models
2
08-19-2009 09:44 AM
Audistic
Audi A4
4
12-19-2006 09:02 PM
SteveZ
General Tech
3
08-23-2006 01:39 AM


Thread Tools
Search this Thread
Quick Reply: Odometer LCD screen no longer working....


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.