Need help.....misfire - AudiForums.com


B7 Models Please discuss all 2005.5 - 2008 B7 A4 topics here...

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-19-2017, 02:14 PM
1st Gear
Thread Starter
 
Join Date: Sep 2016
Posts: 13
Default Need help.....misfire

The car had been misfiring. Ran the codes, cyclinder 2&4. Replaced all the plugs and all the coils on all cyclinders just to be safe. Car ran fine for a week. Did the same thing. Started chugging on take off and idle. It's really bad when you get up to 70 on the highway. Checked codes. Cylinder 1 misfire. Now the check engine light is off but it's still running like a misfire. What else could it be?? Any help would be appreciated.
Reply With Quote
  #2  
Old 04-21-2017, 12:13 AM
1st Gear
 
Join Date: Apr 2017
Posts: 5
Default

Hi,

did you get any other codes along with the misfire?
Reply With Quote
  #3  
Old 04-22-2017, 01:14 PM
1st Gear
Thread Starter
 
Join Date: Sep 2016
Posts: 13
Default

Nope no other codes. Now I just had a cylinder 3 misfire this time. Not number 1 cylinder. And a shitload of smoke blew out the exhaust when it happened.
Reply With Quote
  #4  
Old 04-22-2017, 11:06 PM
1st Gear
 
Join Date: Apr 2017
Posts: 5
Default

I had similar issues with random misfire. It was along with the idle speed high code. I changed the spark plugs and it seems to work. Few months earlier I had changed the relay dealing with the ecm voltage and power. The relay is in the box where the ecm is on the driver side on my B7. It may not be your problem however since you are not getting the voltage code. Not sure what else to say at the moment.
Reply With Quote
  #5  
Old 04-25-2017, 09:09 AM
1st Gear
Thread Starter
 
Join Date: Sep 2016
Posts: 13
Default

Now that I think about it when it first happened it had a code that was like timing advanced??? Something like that. But when it was cleared out it has not come back since. I've been monitoring the timing with the veepeak odb wifi link. I don't know where it's supposed to be but it fluctuates up and down. It's color coded and has never gone in the red range. Assuming the red area is bad.
Reply With Quote
  #6  
Old 04-25-2017, 09:16 AM
1st Gear
 
Join Date: Apr 2017
Posts: 5
Default

I think I spoke too soon. My car misfired yesterday big time. Left it alone and went to work. Came back and the car will not even start now. Cleared codes (random misfire) but no start. So I guess I am back to square one on this.
I will let you know as I go if I manage to get it fixed. If you come across an idea please let me know. I think I will start with ignition coils first but the coils should not kill the entire engine unless they all go at the same time, unlikely. The next one is vacuum leak. I had a problem with the vauum pump and also have a noisy tensioner, some oil leak from the back where the vacuum pump is.
So lots of things to do and check. It is surprising that it was working OK jusat with the spark plugs for some time and then dead:-)
Reply With Quote
  #7  
Old 04-25-2017, 11:29 AM
2nd Gear

 
Join Date: May 2010
Posts: 667
Default

Usually, they throw other codes, but check your fuel pumps. Sounds like it was intermediately not getting the needed fuel and now no fuel at all.
Reply With Quote
  #8  
Old 04-25-2017, 11:03 PM
1st Gear
Thread Starter
 
Join Date: Sep 2016
Posts: 13
Default

So your saying that there would be other codes other than just a cylinder misfire code?
Reply With Quote
  #9  
Old 04-26-2017, 12:32 AM
1st Gear
 
Join Date: Apr 2017
Posts: 5
Default

Thanks for your comments.
I checked the fuel line and it is delivering fuel to the HPFP. I can also hear the in tank pump priming. Haven't checked the HPFP yet.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AWM Misfire Cylinder #2 only at idle. Doesn't misfire with a/c running Russ Heinrichs B5 Models 9 04-25-2017 10:46 AM
random misfire/multiple misfire 4, 5, 6 dorkfish Audi A4 4 05-06-2013 09:58 AM
I need help figuring out a misfire!!! please help JETSPEED333 General Tech 3 04-23-2011 01:16 AM
CEL # 16686 Cylinder 2 misfire, P16684?? Random misfire, '03 A4 1.8T manual A4ENGRSF B6 Models 5 10-09-2010 09:49 PM
Misfire misfire misfire!!!! JohnnyBravoA4 Audi A4 3 01-10-2007 02:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:45 AM.