Computer & Fuel Systems Talk about the computer, fuel systems and delivery, customization and more.

ecs light and more ???

  #1  
Old 04-22-2015, 12:51 PM
1st Gear
Thread Starter
Join Date: Apr 2015
Posts: 3
Default ecs light and more ???

Hi guys n gals newbie here 😉
I have recently bought an a4 2.0 tfsi s-line 2006 , no warranty , say no more !
Only had it a week and the ecs light has come on and when i run the engine check i get an oil presure , coolant and brakes light on dash ??? Have checked all of these and all are good ?????
Any ideas before i go down the expensive road ! Cheers all ,Dan
 
  #2  
Old 04-25-2015, 08:52 PM
1st Gear
Join Date: Aug 2008
Posts: 420
Default

When you say "run the engine check", you mean when you push the check button? If so, all those warnings are normal. It doesn't mean there's a fault. The check is to verify all those warnings can operate. If there is an actual problem, one or more of those warnings will come on all by themselves. In other words, nothing to worry about.
By ECS light are you saying the check engine light or did you mean ESC (electronic stability control) light? Either way, a fault is indicated. First step is to find out what codes are stored and in what system and then diagnose from there.
 
  #3  
Old 04-26-2015, 03:16 AM
1st Gear
Thread Starter
Join Date: Apr 2015
Posts: 3
Default

Hi and thanks for your reply , yes the check button ! All runs OK just those 3 i mentioned where doubled in red and the rest not ? But if thats normal then great 😉 1 less thing to worry about .
And i assumed the engine check light , my manual said emission control system ?? Either way i have ordered a vag off ebay so will do a diagnostic when it arrives , is there a page with codes on here ? I will have a look later .
Wish me luck lol
 
  #4  
Old 05-09-2015, 12:41 PM
1st Gear
Thread Starter
Join Date: Apr 2015
Posts: 3
Default

Seems i have catalyst system efficiency below threshold on bank 1
So either the cat or the o2 sensors ??
Or a leak on the intake or exhaust best case senario lol
Anyone else had this ? Easy fix ?? Or lots of on new cat 😢
 
  #5  
Old 05-10-2015, 08:06 AM
1st Gear
Join Date: Aug 2008
Posts: 420
Default

Assume it's a P0420 code? Cat efficiency codes like P0420 and P0430 are not caused by either the upstream or downstream O2 sensors. The code is set when the downstream O2 (the catalyst monitor sensor) is giving the same or similar signal as the front O2. It means what's going in is the same as what's going out.

Normally, the front O2 will be switching and the downstream should be flat lined at about .450 volts. Only time the downstream should switch is when the ECM is doing a catalyst monitor system test to verify it can work IF the catalyst fails.

Best way is to use a scanner and look at the upstream and downstream O2 graphs. If both are switching the same or the rear is switching but at a slower hertz, you need to go catalyst shopping. As Is aid, the upstream should be switching, the downstream will be flat line on a functioning catalyst. The flat line means the exhaust coming out has been "cleaned" and has a steady oxygen content.

One thing to check also is if there has been an ECM reflash released for your car for P0420. Certain ones, there was due to the program being too sensitive and setting a false code. Even if there is though, if the downstream O2 is switching, it's the cat.
 

Thread Tools
Search this Thread
Quick Reply: ecs light and more ???


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.