Go Back  AudiForums.com > Audi Tech > General Tech
06 A6 3.2l... bad ECM??? PLEASE HELP!!! >

06 A6 3.2l... bad ECM??? PLEASE HELP!!!

General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

06 A6 3.2l... bad ECM??? PLEASE HELP!!!

  #1  
Old 07-09-2018, 11:58 PM
1st Gear
Thread Starter
Join Date: Jul 2018
Posts: 1
Default 06 A6 3.2l... bad ECM??? PLEASE HELP!!!

Hi guys, new hete and need some help.
Ok so here's my story. Try to make it brief but still give some history.
Got my a6 3 years ago and for the most part she has been fine except horrible gas mileage. After few weeks of owning car p2404 came on and ended up replacing my leak detection pump with no success in error code or mpg. Oh well I'll live.
Next, went to do oil change 6 months down the road and figured I'd swap out air filter and plugs and what do I find. An empty air box with remains of a cut out filter cuz the dimwit before me didn't see the 2 retaining screws that hold the filter in the housing. AWESOME!!! Never the less she is still my baby and I'm gonna take care of her.
car was fine for the next year and a halfish. Routinely checked my error codes since I have the p2404 and didn't wanna see anything new until. O2 sensor, 1 on each bank. Bought 2 new ones and put them in and cleared the codes and all is well again.
Then, about a month after the O2 sensors I was driving and went to pass someone and my car felt gutless when it downshifted. Now my car has no power past about 3000rpm. Assuming it's in limp home mode I'm not sure what caused it. Also the car began to have rough starts. Which I then went and had the codes ran again and was now getting a
P1158 (Manifold abs. press. sens. Implausible signal)
P0068 (Throttle position correlation)
P2296 (Fuel pressure regulator "b" control circuit high)
P1136 (bank1 mixture adaption system to lean)
P1138 (bank2 mixture adaption system too lean)

so I'm at a loss of what happened. I had to take my car in to have to airbag recall service done so had Audi diagnose it to see what they think would be the solution and they came back with same error codes and a prognosis of a BAD ECM...

my car just hit 110k, has rough starts and no power past 3k.

if so what would cause my ECM to go out?
o2 sensors? Why would it take a month to damage?

I ended up buying a newer model ecu for $200 out if a recycled car. It's the model that came out in 2012 and the same part number Audi was trying to sell for 1997.99+tax. I've got a 30 day warranty so if it doesn't fix it I'll return it. Going to have it coded to the car tomorrow or the next day for 179+tax.

please any help or advise would be grateful. Thanks in advance
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
norcal89451
B5 Models
9
03-24-2013 03:03 PM
jwestover
Electronics
1
12-25-2012 09:02 AM
Donz0r
B5 Models
10
07-18-2011 12:04 AM
o0darkhaven0o
B5 Models
7
05-11-2009 02:57 AM
aRIf
Audi A4
8
02-04-2007 02:37 AM


Thread Tools
Search this Thread
Quick Reply: 06 A6 3.2l... bad ECM??? PLEASE HELP!!!


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.