2004 A4 CEL and horrible noise - AudiForums.com

Go Back  AudiForums.com > General > Sights N Sounds
2004 A4 CEL and horrible noise >

2004 A4 CEL and horrible noise

Sights N Sounds Upload and Post Video and Sound clips here. This forum is for video's pertaining to Audis, Racing (Street/Strip), Interviews, and Off Topic.

2004 A4 CEL and horrible noise

Reply

 
 
 
  #1  
Old 11-13-2017, 01:45 PM
1st Gear
Thread Starter
Join Date: Nov 2017
Posts: 3
Default 2004 A4 CEL and horrible noise

Have a 2004 A4 3.0L v6. Oil light came on same time as CEL and horrible loud noise and rattling from engine. Only had it 2 days and it purred like a kitten before hand. It was 2 quarts low. Put oil in. Noise didnít stop. Threw 9 codes for map sensor, o2 sensor and misfire on all but one cylinder. Pretty sure my engine is ruined. Having it taken to a shop this week but was wondering what other year motors would fit. Been shopping for an engine pricing them out in case it is screwed. But Iím 99.9 % sure it is.
 

Last edited by Hdiane86; 11-13-2017 at 06:03 PM. Reason: Had code read
Reply With Quote
  #2  
Old 05-17-2018, 12:09 AM
1st Gear
Join Date: Sep 2015
Posts: 55
Default

If you were two quarts low and assuming you were full of oil two days prior I suspect your engine is dicked.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Bradley Scott
Audi A8
27
02-09-2013 08:35 PM
washyourrhands
S Car Model Line
6
02-14-2008 10:34 PM
30vQuattro
B5 Models
0
02-12-2008 02:29 PM
terminaltone
General Tech
2
11-03-2007 01:46 PM
surfbumb321
General Tech
7
08-27-2006 02:12 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors