Go Back  AudiForums.com > Audi Models > All Other Audi Models
 90 2.3L '90 rough idle, stalls, not starting >

90 2.3L '90 rough idle, stalls, not starting

90 2.3L '90 rough idle, stalls, not starting

  #1  
Old 09-14-2006, 02:27 AM
Thread Starter
Join Date: Sep 2006
Posts: 3
Default 90 2.3L '90 rough idle, stalls, not starting

6 months ago after starting my car was running REALLY rough (jumping around like crazy) at low revs, but once you hit about 80km/hr it seemed fine. As long as you kept the revs above 1500rpm it ran smooth as can be. Then it stalled at the lights and wouldn't start again, and hasn't since. It will turn over once but that's it. The mechanic who towed my car had a look at it and said it might be the injectors as he injected fuel into the line and it ran perfectly until the fuel ran out.

However, there's also history to this problem. My car had the same problem about a year ago and the air intake had a huge crack in it, so that was replaced. I've also had the battery, spark plugs, oil, and fuel filter replaced. If the distributor is 'fiddled' with it improved the problem for about a day and then it went back to a rough idle. Also, once it died it would not be restarted for about an hour.

I've had other people tell me it could be the fuel pump (although it does engage when the engine is energized, so it does work, but maybe not well enough?). I've also had them suggest the oxygen sensor and a vacuum leak, although that was before the air intake was fixed.

Where should I start first? Is it worth it to get it scanned even though there is no 'check engine' light? Any and all ideas would be hugely appreciated as I need somewhere to start. Thanks!!
 
  #2  
Old 09-14-2006, 04:37 PM
Join Date: Aug 2005
Location: Brooklyn, NY
Posts: 1,561
Default RE: 90 2.3L '90 rough idle, stalls, not starting

I would think, that if you fixed the air intake, and sure no more leaks. Check that the plate in the air intake is moving, thats your MAF. and check that the Cold start injector does not flood your inatke. couse if it turns where hot, it wont start when hot.
The ignition is also important, is it right?
hmm, The intake makes that problem. so I have no clue, make a video or something so it be eaiser to diagnose.
 
  #3  
Old 09-14-2006, 05:30 PM
Join Date: Nov 2005
Location:
Posts: 12,826
Default RE: 90 2.3L '90 rough idle, stalls, not starting

its a fuel feed issue by the sound of it, cold start injector is a good place to start it should have a resistance of 2 to 4 ohms, next would be the idle air control valve ( you can hear it click when the ignition is turned on ) also have you enough fuel in the tank and any fuel leaks
 
  #4  
Old 09-14-2006, 11:54 PM
Thread Starter
Join Date: Sep 2006
Posts: 3
Default RE: 90 2.3L '90 rough idle, stalls, not starting

The cold start injector is the only one that seems to receive any significant fuel; the others are all 'dry'. Where exactly is the idle air control value? Sorry, I'm new to the fixing rather than driving side of my car! hehe

Also, the fuel tank is half full and I've had no problems with fuel leaks. The ignition is fine as the motor will turn over, it just won't run. I'll check the MAF.

Thanks so much for your responses!

 
  #5  
Old 09-16-2006, 02:11 AM
Join Date: Aug 2005
Location: Brooklyn, NY
Posts: 1,561
Default RE: 90 2.3L '90 rough idle, stalls, not starting

it could be that fuesl pump is weak or bad. or the filter is cloged, or the the filter in the tank is clocked.
 
  #6  
Old 09-16-2006, 09:04 AM
Join Date: Nov 2005
Location:
Posts: 12,826
Default RE: 90 2.3L '90 rough idle, stalls, not starting

hmmm cold start is ok and injecting fuel, is fuel getting to the fuel distributor??

this link give some idea how the system works although its for tuning

http://images.google.co.uk/imgres?im...l%3Den%26lr%3D

also ensure the rubber air pipe from the airbox to the intake has no air leaks and the clips are tight ( any air leak in this area will cause it not to start
 
  #7  
Old 12-05-2006, 04:42 PM
1st Gear
Join Date: Dec 2006
Posts: 7
Default RE: 90 2.3L '90 rough idle, stalls, not starting

Have got a similar problem to you earlier this year the car just died on the way home from work. It turned out that the cataliytic converter was blocked so had to replace it. This can be tested easily by unbolting the front part of the exhust from the cat and then trying turning the engine over.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Tlap
Audi A4
0
04-14-2011 01:43 PM
justinclarke
DIY - Do It Yourself
0
11-25-2010 04:03 PM
alexanderdiluzio
General Tech
3
12-09-2008 01:05 PM
mikesA8
General Tech
2
04-06-2008 04:07 PM


Thread Tools
Search this Thread
Quick Reply: 90 2.3L '90 rough idle, stalls, not starting


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.