Go Back  AudiForums.com > Audi Models > Audi A8
A8/04/3.0 PRNDS Flashing? engine vibrate on Reverse? >

A8/04/3.0 PRNDS Flashing? engine vibrate on Reverse?

Audi A8 This full sized Audi A8 sedan offers interior luxury and spaciousness comparable to any car in the full sized luxury sedan class

A8/04/3.0 PRNDS Flashing? engine vibrate on Reverse?

  #1  
Old 08-24-2008, 02:20 PM
1st Gear
Thread Starter
Join Date: Sep 2006
Posts: 21
Default A8/04/3.0 PRNDS Flashing? engine vibrate on Reverse?

Hi all,

I am going to tell you the wholes story from A-Z

I was driving to my office with no problem, smooth ride. When i left the office i tried to start my car the engine didn't start and i got the PRNDS Flashing and i can't move the transmission stick from the P position.

So i called the agent and they sent someone to check the car, he connected his inspection device, generated a report and then unlocked the transmission. He started the car and it went fine, smooth as usual.

He advised me to take it to the garage to diagnose the issue and make sure everything is ok, i did, they checked it and told me they need to change the TCU.

They changed it and i took the car.. I have two issues now:

1. At the begining, the engine turned off almost 3-4 times in around 20min when i put the transmission in D or R. after an hour drive it went ok, no problem in D but the PRNDS turned ON while i was driving for 5min and then went off, this time it is not flashing.

2. Now When i move the transmission stick to the R position, it is not smooth, it act as if am moving the stick to R while pressing the gas paddle. you can see the engine shock and u can feel it.

I took the car back to the garage and now they are telling me that i need to replace the transmission if i want to get that issue solved!!!!!!!!!!!!!!!!!!!!!!!!!!!!

before that i had a problem with the oil cooler and they replaced it, Please advise
 
  #2  
Old 08-24-2008, 02:35 PM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

Which shop diagnosed this? It still sounds like a TCU problems to me. The transmission won't cause the PRNDS lights to flash, that indicates trans limp mode. Meaning there is an electrical problem so there couldn't be a mechanical problem causing that.
Changing the transmission won't solve anything, take it to another shop and make sure they coded the TCU correctly.
 
  #3  
Old 08-25-2008, 12:36 AM
1st Gear
Thread Starter
Join Date: Sep 2006
Posts: 21
Default

this is Audi Main dealer shop in saudi arabia. I know that they know nothing about fixing Audi but we have no other choice here. As they are the only one to fix Audi.

I will go to them today and ask them to make sure that the TCU is coded correctly.i hope they know how to do that! is there a step by step guide that i can share with them. How can they check if they coded it correctly or not.

Thanks for the help
 
  #4  
Old 08-25-2008, 05:48 PM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

If its a factory dealer then they have to have access to ELSA WEB which will have a specific coding table. Another problem with A8's are the TR (transmission range) switch which could cause this problem. IF its the dealer then tell them to look up all the TSB's for the cars and there might be one relating to your concern. I have only had to replace 1 A8 transmission for a problem like this out of maybe 100.
 
  #5  
Old 08-30-2008, 01:56 PM
1st Gear
Thread Starter
Join Date: Sep 2006
Posts: 21
Default

ok i just took the car out of the garage, they checked the code and they said it is on the factory default for my car. They connected a device in the car and took it for a drive, and then did a transmission alignment or what ever they call it. where they drive for 20 meter on D and then R 20 meter, they did that for 4-6 times. When i drive the car it seems that The problem is 90-95% solved, it is much smoother than before but still sometimes i feel it a little. When you ask some one else to drive my car he will not notice it but i do cuz it is my car ..

After they diagnosed the car, i asked them to dump the result on my USB Drive, maybe i can send it to you to take a look at it and see if there is something in it.
 
  #6  
Old 09-01-2008, 07:01 PM
auditech79's Avatar
Site Moderator
Join Date: Feb 2007
Location: Nor Cal
Posts: 9,004
Default

Yeah you can do that, but im glad that its mostly solved.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Relyts
Audi A6
2
10-08-2014 02:44 PM
Kasim
VAG-COM
1
09-05-2013 11:06 AM
Kasim
Audi A4
0
08-26-2013 08:14 AM
Cuda66
B6 Models
31
07-17-2013 12:20 AM
prototype821
Audi A4
1
07-24-2007 09:46 PM


Thread Tools
Search this Thread
Quick Reply: A8/04/3.0 PRNDS Flashing? engine vibrate on Reverse?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.