Audi A8 This full sized Audi A8 sedan offers interior luxury and spaciousness comparable to any car in the full sized luxury sedan class

engine runs very rough

  #1  
Old 06-20-2013, 07:41 PM
1st Gear
Thread Starter
Join Date: Aug 2012
Posts: 62
Default engine runs very rough

1999 A8, just started today without warning. sounds like a very bad misfire. VCDS says it's cylinder 4. I changed out the plug and the coil. no difference. swapped the ECM with a good spare. no difference. fault codes are P300 & P304 for the misfires, and the third is a P1690 electrical malfunction relating to the MIL (check engine) light not working. doesn't come on when the key is turned, or after starting. I know it was working before this. I scanned the car about a month ago and it was fine. the car can not be driven over about 20 mph, at which point it shakes violently. I've been through every relay I can find. pulled them and reinserted. nothing makes a difference. all fuses I've checked are ok. this happened one other time. I unhooked the battery for an hour, and it cleared up. that was last fall. it's been a-ok till now. tried the unhook battery deal too. no luck. what would make the MIL light malfunction ?
 

Last edited by josh A8; 06-20-2013 at 07:45 PM.
  #2  
Old 06-21-2013, 11:12 PM
1st Gear
Thread Starter
Join Date: Aug 2012
Posts: 62
Default

changed ignition control module. runs great now. still no MIL light. don't know why...anyone know why there are 2 ICMs ?
 
  #3  
Old 09-24-2013, 05:45 PM
chriskapuscinski's Avatar
1st Gear
Join Date: Sep 2013
Posts: 2
Default

Not sure, with these cars age and number of connections it could be just a poor connection. Get some connectivity grease in the spots you visit. Also have watch the ECM pins,.. I had some moisture get into my PLETH box and corrode a pin off and the car wouldn't start. By-passed it and the car fired up as if nothing happened.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
influentialsonny
B5 Models
4
11-13-2013 06:30 PM
b1234c
Audi A6
0
06-27-2013 11:56 AM
andyandjohn
Audi A6
1
07-31-2012 09:17 PM
Tyrell
S Car Model Line
8
07-08-2008 07:30 PM
pumaro
S Car Model Line
2
10-13-2004 03:34 PM


Thread Tools
Search this Thread
Quick Reply: engine runs very rough


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.