Radio/ MMI display not working - AudiForums.com

Go Back  AudiForums.com > Audi Tech > Electronics
Radio/ MMI display not working >

Radio/ MMI display not working

Electronics Wired up? Everyone's got some sort of electrical modification. let's hear about it here.

Radio/ MMI display not working

  #1  
Old 09-11-2018, 01:56 AM
1st Gear
Thread Starter
Join Date: Apr 2016
Posts: 3
Default Radio/ MMI display not working

Dont judge me guys. I had to replace battery on my 2014 A4. I didnt purchase OEM battery. So I made a mistake when connecting battery. when I connected, as you guys know, the battery posts are opposite than american batteries. Now my Radio/ MMI display not working. I've checked every fuse (in trunk and both sides inside of front vehicle). Am I going to have to purchase new display or is there another fuse behind the display/radio? please help
 
Attached Thumbnails Radio/ MMI display not working-img_3159.jpg  
  #2  
Old 10-27-2018, 01:26 AM
1st Gear
Thread Starter
Join Date: Apr 2016
Posts: 3
Default

Anyone? :/
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jonnywill
Audi Q7
15
09-07-2015 08:38 PM
D-NICE
General Tech
0
05-18-2015 01:31 PM
D-NICE
Electronics
0
05-18-2015 01:27 PM
rolnl
Electronics
3
09-23-2014 09:30 AM


Thread Tools
Search this Thread
Quick Reply: Radio/ MMI display not working


Advertising
Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.