2002 s6 avant tranny trouble - AudiForums.com

Go Back  AudiForums.com > General > Dealerships & Mechanics > Mechanics & Workshops
2002 s6 avant tranny trouble >

2002 s6 avant tranny trouble

Mechanics & Workshops Kudos and complaints equally welcome. Know a good one? Know a bad one? Advise/warn others.

2002 s6 avant tranny trouble

Reply

 
 
 
  #1  
Old 07-30-2018, 01:12 PM
1st Gear
Thread Starter
Join Date: Jul 2018
Posts: 2
Default 2002 s6 avant tranny trouble

Sup guys. New here, so please bear with me. I'm having an issue with my tranny. Trying out the forums to see if it's a DIY fix before going to a shop. I'm no mechanic, but I can do some things.


I have a 2002 audi s6 avant. Has a 4.2 v8 engine. Automatic tranny. 175k miles. So my issue is intermittent, when it's not present, my cars a beast. Sometimes when I start my car, and throw it into gear, the tranny lags before it engages, and when it finally engages it's a rough jerk, and typically goes into limp mode where I have to turn the car off and try again. It's more prominent when going into reverse but also gives me trouble when going in to drive. Sometimes when going in to drive the tranny won't go into limp mode and there is no hard jerk but My tranny won't shift. If I push on the accelerator it'll just keep revving higher and higher and it will barely move. After going into ment mode I turn it off started again and repeat the cycle. If I ride the break off as it shifts it is less likely to go into limp. it's normal it's Great. I'm throwing an engine light, but it's for my o2 sensor since my exaughst needs some love.

I suspect it's a sensor, or an electrical issue. My headlights tend to dim out at times, as well as my dash display gets dim at times, like real dim. The transmission problem it worse when the dash is dim. I've noticed my battery voltage seems to fluctuate quite a bit as well, at the same time my oil temp, and coolant temp seems to rise above normal. I've tested both my battery and alternator and both are normal.

I've not checked my trans. Fluid, given theres no dipstick so I'm not sure how to. Feel free to fill me in. I love my car and want to bring it back to life.
 

Last edited by Diamante8181; 07-30-2018 at 01:16 PM.
Reply With Quote
  #2  
Old 08-14-2018, 01:34 PM
4th Gear
Join Date: May 2004
Location: Northern NJ USA
Posts: 4,076
Default

If you have a VAGCOM code reader, check for trans. codes. Having the trans. fluid and filter changed might help. Good luck.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
eric76
Audi A6
2
03-25-2012 10:54 PM
b taylor
General Tech
0
05-01-2011 01:54 PM
kaneka
B5 Models
2
09-09-2010 02:58 PM
illspirit
Audi A4
4
11-30-2006 12:27 AM


Thread Tools
Search this Thread
Quick Reply: 2002 s6 avant tranny trouble


Advertising
Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.