Go Back  AudiForums.com > Audi Tech > Electronics
2009 A6- Complicated MMI 2G/3G satellite radio issue >

2009 A6- Complicated MMI 2G/3G satellite radio issue

Electronics Wired up? Everyone's got some sort of electrical modification. let's hear about it here.

2009 A6- Complicated MMI 2G/3G satellite radio issue

  #1  
Old 02-24-2019, 08:07 AM
dschwartz2's Avatar
1st Gear
Thread Starter
Join Date: Aug 2013
Posts: 15
Default 2009 A6- Complicated MMI 2G/3G satellite radio issue

Bear with me, this one is complicated...Several months, the MMI setup on my 2009 Audi Avant started cutting in and out- the stereo would go dead and the entire display went blank. It did this intermittently, worked fine for a while, them went completely dead. My independent shop tried replacing several sub-computers with no luck, then finally suggested the dealer as Audi Tech support won't talk to an indy. The shop also tried a ton of things before finding, by luck, that it was a wiring harness issue! (He literally pulled on a wire by accident and the power came on!). Their conclusion was that intermittent power on/off had been the source of damage to several of the subcomputers. They replaced the harness and its working again (separate issue that they installed the wrong software- my car does NOT have TPMS sensors, it uses ABS, or oil pressure monitoring but the MMI version they installed thinks it does!)- but they are on track to get that corrected.

My remaining issue is the satellite radio- they concluded the Satellite computer was also fried, and looped around it. They said a replacement was $1000, but I found a used one on E-bay for $60. They are concerned that replacing it (whether with a new or used one) might fry other components and recommend I not try. BTW, the dealer had their top tech working on it basically non-stop for 2 weeks, and replaced 3 computer modules- and the total bill was $3000, so I know they are trying to be fair and straight with me. (The indy shop wrote off their entire bill since they couldn't fix it BTW!)

My thought is that if the problem was the wiring harness and that is fixed that replacing the satellite unit shouldn't be a big deal or risk the rest of the system. Any thoughts???
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sshhbequiet
B5 Models
7
12-12-2010 01:25 AM
mhellman
B5 Models
9
04-30-2008 11:31 PM
audichicks4
Audi A4
30
01-22-2008 09:53 AM


Thread Tools
Search this Thread
Quick Reply: 2009 A6- Complicated MMI 2G/3G satellite radio issue


Advertising
Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.