Go Back  AudiForums.com > Audi Models > All Other Audi Models
 94 Audi 100 S Ignition Switch Problem... >

94 Audi 100 S Ignition Switch Problem...

94 Audi 100 S Ignition Switch Problem...

  #1  
Old 09-29-2005, 04:12 PM
Thread Starter
Join Date: Aug 2005
Posts: 4
Default 94 Audi 100 S Ignition Switch Problem...

Wipers, turn signals, etc. do not operate sometimes.. have to turn in ignition several times before it chooses to work.. My mechanic wants $250 to fix it.. I would like to do it, if it is a Do-it-yourself job.. Can the wise men in this forum give me some pointers on how to fix the ignition switch? Seems like the part is only $10 on www.europartsdirect.com.. I have absolutely no mechanic experience..

And on a totally different note, my gas mileage is crappy.. i get like 13-15 mpg in the city, and around 20-22 in the highway.. could it be a transmission problem? my shift from 2nd gear to 3rd gear is not always smooth.. there is a jerk sometimes.. had a tranny flush done recently..

Any help will be GREATLY appreciated!!

Thanks
 
  #2  
Old 09-29-2005, 07:25 PM
2nd Gear
Join Date: Mar 2004
Location: Swamplands of NJ
Posts: 761
Default RE: 94 Audi 100 S Ignition Switch Problem...

Changing the ignition switch can be a real PITA. Often there are special security bolts that have to be removed with special sockets or have to be drilled out. I have done it in the past but not on an Audi. I don't recommend it if you absolutely have no mechanical experience.
 
  #3  
Old 09-29-2005, 09:52 PM
Thread Starter
Join Date: Aug 2005
Posts: 4
Default RE: 94 Audi 100 S Ignition Switch Problem...

Thanks for the response offramp!! I actually found a link which shows the step by step procedure..
http://www.audifans.com/twiki/bin/vi...hReplacementC4
Seems like it shouldnt be that difficult.. what do you think? and do you have any thoughts on crappy gas mileage or is it normal for a 10 yr old car?

thanks
Pradeep
 
  #4  
Old 09-29-2005, 11:25 PM
2nd Gear
Join Date: Mar 2004
Location: Swamplands of NJ
Posts: 761
Default RE: 94 Audi 100 S Ignition Switch Problem...

The procedure seems quite simple, give it a try. At least you don't have to disassemble the steering column that would be murder. Actually the switch and dash assembly looks very similar to my 91 100.

As for the mileage, 22MPG on the highway with an automatic is not bad for a V6. What octane do you use? My 1991 100Q gets about 26 MPG on the highway during the summer with 93 octane, with 90-91 octane it gets me about 22-23MPG. In the winter I get 22MPG with super or plus grades. This is due to denser air to push through as well as the fact that on the North East coast we have oxygenated gasoline witch is known for low fuel economy. However the 13-15 city mileage sucks but I don’t know what it is supposed to be for your car. You can try changing brands of gasoline, switch to higher octane, check your tire pressure and vary your driving style. If you redline from red light to red light you will burn fuel like jet airplane.
 
  #5  
Old 10-03-2005, 12:32 AM
1st Gear
Join Date: Feb 2005
Location: SW PA
Posts: 368
Default RE: 94 Audi 100 S Ignition Switch Problem...

I don't think it's the ignition switch. Schematic and line drawing of the switch show just 5 wires coming from the switch, 1 for the headlight relay, one for the engine check system, I don't think any going to the combination switch.

That might be your better bet, checking for loose connectors or corrosion on the combo switch connectors.

Careful with that one. Read the book and disconnect the Air Bag before you try to remove the horn pad to pull the steering wheel.

Also possible, check the relay and fuse box, on the lid are the descriptors for all the relays. I don't know if there is one relay to power all that you say does not work. I know on mine, per the book, 1 fuse feeds the wiper, turn signals, radiator fan thermoswitch, and the washer nozzle heaters. Perhaps 1 relay doing the same isn't making contact or pulling in when ignition turned on.

I'll check my own in the morning, you got me curious.

Cheers,

George
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ariegeben
General Tech
0
09-25-2012 11:29 AM
Ariegeben
B5 Models
0
09-25-2012 11:20 AM
tonygump
B5 Models
0
08-01-2011 11:29 PM
paul3141
B5 Models
0
06-26-2010 03:39 AM
RUGBY23
Audi A4
3
07-07-2006 08:07 AM


Thread Tools
Search this Thread
Quick Reply: 94 Audi 100 S Ignition Switch Problem...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.